Issue with Ctrl + Alt + Arrow Key Combinations Being Intercepted in Remote Desktop

Copper Contributor

Hello,

I’ve been experiencing an issue with my Remote Desktop connection. Specifically, I’m unable to use the key combinations Ctrl + Alt + Left Arrow and Ctrl + Alt + Right Arrow in an application on my computer while using Remote Desktop to connect to that computer. These key combinations are not being sent to my application, but instead, they are being intercepted by the Remote Desktop Client or the Remote Desktop Protocol (RDP) server implementation.

I’ve done some research and found that these key combinations are reserved by the Remote Desktop Client. Their only effect is to switch me back to the host computer. This seems to be an intended feature that was never fully programmed and completed, but there is no way to turn it off.

I’ve tried a few potential solutions to this problem, but unfortunately, they didn’t work for me. I tried changing the Keyboard Settings in RDP by selecting “On the remote computer” in the Local Resources tab, but this didn’t solve the issue. I also considered using the Microsoft Store version of RDP and translating the hotkeys on both client and server using Auto Hotkey, but I prefer not to use another application.
Best regards, [Vahid]

2 Replies
As of now, it seems there is no solution to this issue other than avoiding the use of Ctrl + Alt + Left/Right Arrow key combinations while using Remote Desktop. Alternatively, you may try using other remote access tools such as TeamViewer, AnyDesk, or Chrome Remote Desktop that do not have this limitation.

@Tukstin1835 


I need such a combination for Jetbrains Tools too.

The 2024 State of this:

 

* Remote Desktop App from Windows Store:
   CTRL+ALT+Left/Right working
   but connection connection in this app is not reliable 

 

* Basic RDP Client on Win10
   CTRL+ALT+Left/Right not working

 

* Basic RDP Client on Win11
   CTRL+ALT+Left/Right working