File Explorer Cannot Find Folders on my Router

Copper Contributor

Yesterday I did a fresh install of Windows 10 because the File Explorer in Windows 11 wasn't locating partitions on a flash drive in my router. But now Windows 10 isn't seeing it either.

Here are snaps of the way it looks now (top), How it looked when it worked (middle), and the info about the old Windows 10 last:New File ExplorerNew File Explorer

W, X, & Y are the 3 PartitionsW, X, & Y are the 3 PartitionsAnother viewAnother view

2 Replies
You can try these steps:

1. Make sure your router firmware is up-to-date. Sometimes compatibility issues can be fixed with a simple update.
2. Check if your router settings are set to allow sharing for these partitions.

I see this thread is a year old, so you might have already found a solution to your problem. However, for you or anyone else facing similar issues, let me offer some advice.

 

File Explorer not locating partitions can be quite frustrating. If you've already tried a fresh install of Windows 10 and it still didn't work, the issue could be with your router settings or compatibility between the router and the Windows versions you're using.

 

There's a website that offers various guides and troubleshooting advice, including support for your router. They could have tips that are specific to your router model, which might help resolve your issue.