error with gtx 960m graphics card on my dell inspiron 7559 laptop......

Copper Contributor

so i just got this laptop second hand on carousell a feww days ago and everything seems fine until i tried updating the gpu driver, then the laptop will freeze after the nvidia updater says that the driver has finished installing, and then proceeds to give me a blue screen error of driver power state failure. I then went into safe mode and deleted the driver and i can finally reboot my laptop but the laptop doesn't seem to use the gtx960m when im gaming even when it is shown in the device manager. The nvidia control panel does not work too and it says something that goes along the line of this software is not compatible with your driver. I also tried installing the driver from dell's official website but even when it seems to have installed without crashing the graphics card still ain't working. Also sometimes there will be an error 43 message after i changed the driver. I've also tried installing gpuz and check the gpu info and i can see that a lot of the gpu's info is unknown there. The last time i tried installing the newest gpu driver the same freezing happened, but instead of the driver power state failure error i got the dpc watchdog violation one. I've attached the dump file in this post as i'm not familiar as to what the results mean.


0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL
or above.
Arg1: 0000000000000001, The system cumulatively spent an extended period of time at
	DISPATCH_LEVEL or above. The offending component can usually be
	identified with a stack trace.
Arg2: 0000000000001e00, The watchdog period.
Arg3: fffff8061a0fb320, cast to nt!DPC_WATCHDOG_GLOBAL_TRIAGE_BLOCK, which contains
	additional information regarding the cumulative timeout
Arg4: 0000000000000000

Debugging Details:

***                                                                   ***
***                                                                   ***
***    Either you specified an unqualified symbol, or your debugger   ***
***    doesn't have full symbol information.  Unqualified symbol      ***
***    resolution is turned off by default. Please either specify a   ***
***    fully qualified symbol module!symbolname, or enable resolution ***
***    of unqualified symbols by typing ".symopt- 100". Note that     ***
***    enabling unqualified symbol resolution with network symbol     ***
***    server shares in the symbol path may cause the debugger to     ***
***    appear to hang for long periods of time when an incorrect      ***
***    symbol name is typed or the network symbol server is down.     ***
***                                                                   ***
***    For some commands to work properly, your symbol path           ***
***    must point to .pdb files that have full type information.      ***
***                                                                   ***
***    Certain .pdb files (such as the public OS symbols) do not      ***
***    contain the required information.  Contact the group that      ***
***    provided you with these symbols if you need this command to    ***
***    work.                                                          ***
***                                                                   ***
***    Type referenced: TickPeriods                                   ***
***                                                                   ***


    Key  : Analysis.CPU.mSec
    Value: 3671

    Key  : Analysis.DebugAnalysisManager
    Value: Create

    Key  : Analysis.Elapsed.mSec
    Value: 3670

    Key  : Analysis.Init.CPU.mSec
    Value: 593

    Key  : Analysis.Init.Elapsed.mSec
    Value: 9008

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 94

    Key  : Bugcheck.Code.DumpHeader
    Value: 0x133

    Key  : Bugcheck.Code.Register
    Value: 0x133

    Key  : Dump.Attributes.AsUlong
    Value: 8

    Key  : Dump.Attributes.KernelGeneratedTriageDump
    Value: 1

FILE_IN_CAB:  082022-45187-01.dmp

  Kernel Generated Triage Dump




BUGCHECK_P3: fffff8061a0fb320




PROCESS_NAME:  Discord.exe

fffff806`1f232c88 fffff806`1982a998     : 00000000`00000133 00000000`00000001 00000000`00001e00 fffff806`1a0fb320 : nt!KeBugCheckEx
fffff806`1f232c90 fffff806`19650fed     : 000001ac`e56e3bd2 fffff806`16567180 00000000`00000246 00000000`0000ad57 : nt!KeAccumulateTicks+0x1dcbc8
fffff806`1f232cf0 fffff806`19651591     : 00000000`0000ad56 00000000`00006751 fffff806`16567180 00000000`00000001 : nt!KiUpdateRunTime+0x5d
fffff806`1f232d40 fffff806`1964b403     : fffff806`16567180 00000000`00000000 fffff806`1a0317b8 00000000`00000000 : nt!KiUpdateTime+0x4a1
fffff806`1f232e80 fffff806`19653e02     : fffff806`1f22ade0 fffff806`1f22ae60 fffff806`1f22ae00 00000000`00000002 : nt!KeClockInterruptNotify+0x2e3
fffff806`1f232f30 fffff806`196d9405     : 00000001`9d5d4487 fffff806`1a0f3a20 fffff806`1a0f3ad0 fffffcd2`8f8c2c5d : nt!HalpTimerClockInterrupt+0xe2
fffff806`1f232f60 fffff806`197fa36a     : fffff806`1f22ae60 fffff806`1a0f3a20 00000000`00000000 00000000`00000000 : nt!KiCallInterruptServiceRoutine+0xa5
fffff806`1f232fb0 fffff806`197fa8d7     : fffff806`1f22af10 00000000`00000170 fffff808`44e06ba8 00000000`002e3c90 : nt!KiInterruptSubDispatchNoLockNoEtw+0xfa
fffff806`1f22ade0 fffff808`444f9a7c     : 00000000`00000000 00000000`00100d74 ffffd18f`89d3e000 00000000`00000000 : nt!KiInterruptDispatchNoLockNoEtw+0x37
fffff806`1f22af70 00000000`00000000     : 00000000`00100d74 ffffd18f`89d3e000 00000000`00000000 00000000`00000020 : nvlddmkm+0x99a7c

SYMBOL_NAME:  nvlddmkm+99a7c

MODULE_NAME: nvlddmkm

IMAGE_NAME:  nvlddmkm.sys

STACK_COMMAND:  .cxr; .ecxr ; kb


FAILURE_BUCKET_ID:  0x133_ISR_nvlddmkm!unknown_function


OSNAME:  Windows 10

FAILURE_ID_HASH:  {f97493a5-ea2b-23ca-a808-8602773c2a86}

Followup:     MachineOwner
0 Replies