Dynamic Lock not working due to bluetooth issue on W10 1809

Iron Contributor

Recently we upgraded some workstations to 1809.

On those workstations we upgraded, the dynamic lock doesn't work anymore as it should be.

The pairing with the phone works, but the bluetooth connection seems to be dropping immediately after the connection is made. 

This makes the Dynamic Lock to mall-function.

I can't figure out why this is happening... I checked network connection settings, I checked the phone settings, but I can't figure out what is causing this issue.


Anyone having this issue? 

Help would be great , c'us troubleshooting bluetooth ain't easy :) 

1 Reply

@Matthias Vandenberghe 

For what it's worth, I have same problem on my desktop at home.  After a particular update, my computer lost bluetooth.  Therefore, I receive the same error message on the dynamic lock.  I've tried everything I could find online, but can't fix it. I've tried tech support such as Geek Squad, but they just tell me my computer doesn't have Bluetooth.  Of course it had Bluetooth, I used it on a regular basis.  I think it was Broadcom.  Anyway... thank you for letting me know I'm not the only soul this has happened to.


Good Luck!