Desktop Background Image by script

%3CLINGO-SUB%20id%3D%22lingo-sub-991517%22%20slang%3D%22en-US%22%3EDesktop%20Background%20Image%20by%20script%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-991517%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20an%20startup%20script%20running%20picks%20a%20random%20image%20from%20a%20pool%20and%20places%20it%20in%20%25programfiles%25%5Cmycompany%5Cdekstop.jpg%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDuring%20logon%20we%20change%20the%20users%20desktop%2C%20poiting%20to%20this%20image.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%3A%20The%20user%20doesnt%20see%20this%20image%2C%20but%20an%20other%20one.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20strange%20thing%20is%3A%20when%20the%20user%20wants%20to%20change%20the%20desktop%20image%2C%20in%20the%20preview%20window%20the%20correct%20image%20is%20shown.%3C%2FP%3E%3CP%3EAlso%2C%20running%20%22RUNDLL32.EXE%20USER32.DLL%2CUpdatePerUserSystemParameters%201%22%20will%20fix%20the%20desktop%20imidiatly.%3C%2FP%3E%3CP%3EI%20added%20this%20in%20the%20login%20script%2C%20but%20that%20doesn't%20seems%20to%20have%20any%20effect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

We have an startup script running picks a random image from a pool and places it in %programfiles%\mycompany\dekstop.jpg

 

During logon we change the users desktop, poiting to this image.

 

However: The user doesnt see this image, but an other one.

 

The strange thing is: when the user wants to change the desktop image, in the preview window the correct image is shown.

Also, running "RUNDLL32.EXE USER32.DLL,UpdatePerUserSystemParameters 1" will fix the desktop imidiatly.

I added this in the login script, but that doesn't seems to have any effect.

 

0 Replies