Cumulative update KB5001330 fails to install

Iron Contributor

Hello Everyone ! I am getting an error for installing update KB5001330 Windows 10 version 20H2. I have no idea how to fix the issue. I have troubleshooted windows update but it wasn't helpful. I have made 4 back to back attempts to install KB5001330 but failed every time. I am looking for your kind help. The latest update has the same issue we had been facing with KB5000842 in the last two weeks

171 Replies
I'm having the same error, and I also had that with KB5000842. Currently on a 21H1 install in the Beta Channel on Windows Insider Program.
i got the same problem like you, both version (KB5001330) with error code : 0x800f0984 & (KB5000842) with error code : 0x800f081f

i wish Microsoft will notice
I believe those are the Windows Updates that concern printing problems. Haven't they put those updates on hold until they are fixed?

@Jauhar same issue here on 19042.844 (20H2).
Updates KB5001330 & KB5000842 fail to install.

Moreover my windows indsider program keeps telling me that it has to "fix a problem" and is unable to do so.

So no more updates installing and no more build incoming... nice move.


Same issue here (with both updates). It just keeps rolling it back. What I have tried:
-Making sure all drivers are up to date
-Running DriverStoreExplorer and removing all old drivers.
-Removing the MS update SoftwareDistribution folder and retrying.
-Turning off all none-MS services and apps on boot-up

I always get the error: 0x800f0922
No this new one is the 04-2021 cumulative security patch. The older one was to remove Adobe Flash support.

@Jauhar I was suffer with exact same situation.

It happens if you're using UEFI and your OS disk doesn't have EFI and MSR partition.

You have to recreate both of partition.

before you create it, you have to secure at lease 500MB from OS disk.


Open command>


select disk 0(your OS installed disk)

create partition efi size=300
format quick fs=fat32 label="system"
create partition msr size=128


hope it will help






I'm on Win10Home 20H2 (build 19042.685 Windows Feature Experience Pack 120.2212.551.0) and having update issues since Jan 2021 too. Many updates failed; some tried repeatedly to update, re-downloaded, and failed again wasting my bandwidth! And some of the same failed updates, mysteriously disappeared after a few tries! Not sure if Microsoft finally recalled them and that's why they disappeared?! e.g. Update KB5000842 tried for almost 2 weeks and it failed and as of yesterday, it mysteriously disappeared, but now I'm having the same issues as you with KB5001330, it says, Failed to install on ‎4/‎15/‎2021 - 0x800f0984!
To everyone having this problem with KB5001330, I spoke with a Microsoft support agent last night after a day of trying various different file checking solutions. I have been getting this error (0x8007000d) which basically means that there are corrupted files within the update. The agent said, in response to me listing a number of the solutions i've tried, that I should reset windows on my computer. Basically I think it just uninstalls a bunch of updates so you can add them back in their original state (I am not great with computers, bear with me) I notice we all seem to have different error codes, but I am going to attempt the reset in about an hour I will report back if it works. You can keep all your personal data they just recommend you make a recovery drive to back up a couple system files so I'm going to get a USB. I will keep yall posted.
Hi Johnny
I'm having the same issue and wonder if I need to do the same. In your above command, what're the size 300 & 128 in, KB, MB, GB? Thanks.

Below is the output of my Diskpart info, please tell me if you observe the issue too:

Microsoft Windows [Version 10.0.19042.685]
(c) 2020 Microsoft Corporation. All rights reserved.


Microsoft DiskPart version 10.0.19041.610

Copyright (C) Microsoft Corporation.
On computer: STAR

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ------------- ------- ------- --- ---
Disk 0 Online 931 GB 0 B *
Disk 1 Online 57 GB 0 B

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> list volume

Volume ### Ltr Label Fs Type Size Status Info
---------- --- ----------- ----- ---------- ------- --------- --------
Volume 0 D DVD-ROM 0 B No Media
Volume 1 C Windows NTFS Partition 909 GB Healthy Boot
Volume 2 SYSTEM FAT32 Partition 260 MB Healthy System
Volume 3 WinRE_DRV NTFS Partition 1000 MB Healthy Hidden
Volume 4 LENOVO_PART NTFS Partition 20 GB Healthy Hidden
Volume 5 E DBAN-1_0_7 FAT32 Removable 57 GB Healthy

I reset my PC to factory OEM reset on 4/10 and still get the errors. Microsoft and their support staff and even volunteers on their community sites are very dismissive and always assume it's us and not them! The updates have turned into an endless cat & mouse chase. There are numerous articles in major media venues about these issues and Microsoft is still not acknowledging that it's them, simply because the updates have worked for a few but not the rest of us.

Hi Ken
It's MB. Here is my Disk Status.

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> list partition

Partition ###   Type                   Size          Offset
-------------     ----------------   --------    --------
Partition 1        Primary              953 GB       32 KB
Partition 2        System              300 MB     953 GB --> EFI Partition
Partition 3        Reserved           128 MB     953 GB --> MSR Partition

it works your partition style should be GPT.
you can find out your partition style from input 'Get-Disk | ft -auto' in Windows PowerShell.



Great, thank you Johnny.

Mee too :cry:

Hope to fix soon

Open windows service console using services.msc
look for windows update service right click select restart.

Type troubleshoot on start menu search, select troubleshoot settings,
Click on additional troubleshooter, select windows update and click run the troubleshooter.
Reboot windows once the diagnose completes and check for updates again.

@Johnny_KimYour answer pointed me in the right direction to fix the error by myself.

In my case, the KB5001330 was installing successfully, then the computer restarted, then at 96% the update failed and rolled itself back, and after another restart i went to Windows Update to see the error number 0x800f0922. In my case, the reason for the failure was that my EFI partition was missing some files.


So, TL;DR: I fixed the error by replacing the \EFI\Microsoft\Boot directory on the EFI partition with the contents of C:\Windows\Boot\EFI.


The long story:


DISCLAIMER: this is technical, I do not take any responsibility, etc.


The EFI partition should contains the following directories:




... and if you dual-boot it may contain other directories, but that's irrelevant.


In my case the problem was, my EFI partition has got corrupted a month ago, and Windows, in its attempt to fix it, has broken it even more, the result being:

- some files and directories in \EFI\Microsoft\Boot went missing,

- in the root directory of the partition, several hundred files with randomly-numbered names have appeared.


This was preventing the KB5001330 update from installing.


So, first I assigned the drive letter to the EFI partition - it is normaly not assigned. I opened the cmd shell in administrator mode and entered "mountvol p: /s" (see here for details). The EFI partition became visible as the P: drive.


Then I removed all the randomly-named files from the root directory of P:\


Then I removed all the contents of the P:\EFI\Microsoft\Boot directory. Some of the files there were protected from deletion (in particular,BCD and BCD.log), so I just left them intact.


Then I copied the contents of the C:\Windows\Boot\EFI directory to P:\EFI\Microsoft\Boot. This way I restored the correct contents of the EFI partition.


Then I rebooted, to verify that the system still runs properly. (By the way, you do not need to unassign that drive letter P: - it disappearsafter reboot.)


Then I went to Windows update and proceeded to install KB5001330 again. This time it went smooth.


Note that the size of my EFI partition is 100MB; the standard size as created when installing Windows 10 from scratch. The size was not an issue in my case - I have 73 MB free on the EFI partition and it was enough to install KB5001330.


To reach my success, I used some information about restoring the EFI partition from this article. In my case it was not necessary to restore the whole partition from scratch, but if my solution does not help some of you, you might want to do the full restoration as described in that article.

Windows 10 Pro, 20H2, 19042.906, Windows Feature Experience Pack 120.2212.551.0, 32-bit O/S:


I restarted the update service, ran the troubleshooter and rebooted.  Update KB5001330 continues to fail with error code 0x800f0984.  Internet searching suggests the error code indicates component folders exist but component installer files are missing.


This issue kinds of seems like it is going to be:  hold our breath and hope for an eventual fix.  If components are missing, there isn't much we can do about that.  I am going to pause updates for a few weeks so that my computer doesn't waste bandwidth trying the install repeatedly.

Hey everyone, I was the one who was going to reset windows based on the recommendation of a Microsoft support agent, the problem was not fixed. I wrote the error code I was experiencing in my previous comment for the record. I'm gonna get on microsoft support again later, I don't have high hopes it'll be fixed today but I don't see this harming our computers in the long term. It's not a major update and as far as I know you can install newer updates without installing a previous one. Moreover, we should all just keep being vocal with our problems to microsoft and I believe a fix will be found soon.


I have 3 laptops with Windows 10 Pro, all Dells:

- Latitude E7450 - no problem with update.

- Precision 7510 - no problem with update.

- Precision 5510 (my main workstation) - I tried all possible options and nothing worked for me.

I don't have any suspicious applications nor games installed, all my computers are very clean. I use Norton360, and all computers are virus and malware free.


Below is what I tried:

1) I downloaded from MS site the windows10.0-kb5001330-x64_48f2955cc5688bf56b32be1cca4cd1f02f1d36e2.msu file. It didn't work, the same result as when I used the standard "Windows Updates". I'm found in OS logs message: "Installation Failure: Windows failed to install the following update with error 0x8007000D: 2021-04 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5001330)."

2) I downloaded from MS windows the update file, and proceeded using "dism /online /add-package /packagepath:.\" from terminal window as administrator.

The same result as in #1.

3) Checked images using DISM and SFC

a) SFC /scannow

b) DISM /Online /Cleanup-Image /CheckHealth

    This step reporter that the image can be repaired.

    Note: After cleaning and  (step 3c and 3d) and next update retry I'm getting "the image can be repaired."

c) DISM /Online /Cleanup-Image /ScanHealth
d) DISM /Online /Cleanup-Image /RestoreHealth

e) DISM /Online /Cleanup-Image /CheckHealth

    Everything looks clean.

4) Repeated steps 1 - 3 twice...


On Monday and Thursday I spend more than 4 hours of my time, it's ridiculous that vendor of commercial grade operating system doesn't have solution...

I'm not planning to spend more time on it, but if somebody would find an "silver bullet", please let me know.