Application using libeay32.dll gives Access Violation 0xC00...5 and fails to write dump to TEMP

Occasional Visitor

Hi All,

 

I have a legacy application compiled with VS2013 and uses libssh/libssl 0.9.8. The application is deployed by folder copy all relevant executables, debug files, and dlls are co-located in the same folder. Since Windows 7 we have not had any problems. The domain user account has always been able to run without issue. Today, we have migrated to a HP Zbook 840 G8 and are getting Access Violations reported to the Windows Event viewer with code 0xC00...5. In addition, our crash dump files no longer write to the user's %TEMP% folder.  Therefore we can't get the dump file to debug and we can't resolve the crashing problem. Here are more details:

 

  • HP Desktop 8100, 8200, and 8300, and also laptops 9470m, 9480m, 840 G3, 840 G5, 840 G6, and 840 G7 all work also running Windows 10 1909 18363.1621 Enterprise
  • Windows install is a standard image. 
  • DEP is only configured to run on the Windows system files
  • We've tried copying the application folder to different locations on C drive and desktop
  • We've tried running as administrator
  • Disabled the firewall
  • Verified folder permissions for domain users are correct
  • Verified the user can manually create folders in %TEMP%
  • Changed application to try to write a dump file into the current runtime directory - again worked on other computers, just not the Zbook G8  
0 Replies