1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's

Occasional Contributor

1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's


This will be the very first question I will ask in the AMA.  I hope you have a better answer than "we are working on it" ready for the thousands of us with this issue and waiting for a fix since September.

222 Replies

Hi Steven,

I'll put in some more detail about how I got my system to update in the hope its of some help to anyone.

After updating bios to 1004 I made some adjustments to bios PCH Storage Configuration and Boot -> CSM before upgrading to FCU1709.

For PCH Storage Cofiguration I set:

SATA Controllers to disabled (the topmost option). I enabled it again once the upgrade was complete.


For Boot ->CSM I set it to enabled

Boot Devices Control set to UEFI only

Boot Network and Boot Storage Devices set to ignore

Boot from PCIE expansion devices to UEFI first


I updated from USB using a fresh copy built with the Media Creation Tool (FCU 1709).

I started the update from windows.


Update went through smoothly. After the update I had to reinstall my antivirus and a few drivers but nothing drastic. Ive read about other experiencing that from the 1709 update but it wasnt a drama to fix. I only noticed something off with a few drivers when stressing my machine with an intensive game after the update.

Seems spot on now. Hope this info helps.

This is not a fix for the layman PC user out there.  These are BIOS tweaks for a very experienced user.  The bottom line is the new BIOS 1004 from ASUS does not fix the 1709 upgrade problem for people, and still nothing from Microsoft.  Microsoft nor ASUS has done a thing to help people upgrade from 1709 if they have a NVMe M.2 SSD drive.  

I have the same issue with the 1709 windows update with an x299 motherboard and a samsung 960 ssd NVME...please fix it ASAP!!!!

I know that the bios update fixed it for me . I want to add for those who might still have the issue after updating to the new bios from asus that I was on the microsoft nvme driver when I did the update. I've done this because of the current firmware issue with the 960 pro. This might help or not I don't know.

Another 2 hours wasted making the attempt.  I uninstalled the Samsung NVME driver, rebooted, ensured the MS NVME drive was in use, performed the upgrade attempt using the Windows 10 upgrade assistant and same BSOD result.  This is getting very tiresome.

Well, it looks like there was nothing in the patch Tuesday cumulative update for December.  So no fix for us trying to upgrade to 1709 goes on and on from Microsoft. 

The Asus 1004 bios fixed it for me. I didn't have to do any bios tweaks that Tim Gall did. I just updated the bios, re-ran the Windows 10 Update Assistant (didn't create USB media), and then the update went through smoothly.


My config:

ASUS Prime X299-Deluxe

Samsung 960 Pro (Samsung NVME driver)



Microsoft released yesterday a new Update called KB4054517.


Will try this update, hope it will fix the 0xc00000bb error for nVME drives.


@Erkan Isik wrote:

Microsoft released yesterday a new Update called KB4054517.


Will try this update, hope it will fix the 0xc00000bb error for nVME drives.



Please let us know if this works.  Thanks. 

Nope KB4054517 (12.12.2017) also didn't work. Got still the Error 0xc00000bb.

I did try it with the normal Win Updater and with the Upgrade Assistent, both got the error.


It really feels like a joke that Microsoft and the Manufacturers didnt patch it already. 1709 was released end of October. Now we have mid December and it's still not fixed...



We are continuing to work on it.  A few points:


  • The December update does not include a fix for this problem.  We are hoping to have a fix in place by the end of January.
  • The updated Asus firmware (1004) has addressed the issue for many people.
  • There is a block in place that keeps Windows Update from offering Windows 10 1709 to affected systems.  But if you go into Settings and manually check for updates, this bypasses the block because you are "seeking" the update.



Thanks for the update Michael.

Is there any indication as to why the 1004 update did not resolve it for everyone?

Did MS work together with ASUS on this update? 

Is there something those of us whom 1004 did not resolve the issue could try?

Are there other factors which could interfere?  Installed Memory size, video card, etc?


In my case, another member with the same motherboard, m.2 drive and using the ms nvme driver was able to perform the upgrade.  I replicated that configuration and mine was not successful.


Thanks for the update Michael, really appreciate it!

Will wait till end of January and check back then :)

The basic problem:  Memory fragmentation during system initialization forces IO buffers into high memory.  So yes, the hardware in the system has a definite impact on that fragmentation (each device reserves an address range).


While we have provided details about the issue to ASUS, we are not aware of what they changed in the 1004 firmware.




I tried upgrading to 1709 after the ASUS BIOS upgrade to 1004 and still a no go.  I still get error 0XC00000bb.  

Hello! My name is Michele, from Italy. I've a Samsung 960 Pro on MSI X99A Workstation (beta bios v. 1.15), and even my system suffers of this issue. Error 0xc00000bb, if I update via Windows Update or Windows Update Assistant; error 0xc1900101 - 0x20017 if I try to update via Media Creation Tool. My PC is a custom built Xeon based workstation, and I use it for my work, so I can't have a clean install...


I have tried to open a ticket with MSI. MSI tried to install the update on a system like the one I have, and they said "no problems here!" and closed the ticket. The official bios release is locked at 1.0 (2016). They sent me a beta bios (1.15) but I still have the issue. 


Now Windows Update did another download... I hope to have my troubles fixed, but I don't think so. I'll wait for the next release...



So when i used windows upgrade assistant it basically messed up my pc and turned from the initial error code 0xc00000bb to error code  0x80242006.


Any idea how to fix this? 

I've looked online and tried a few things and none seemed to have worked.


Obviously once this has been fixed i'd still have the error code 0xc00000bb waiting for me but at least I've ticked off one in the process.


Also I know Asus is probably the most popular brand of motherboards but have you guys been in contact with MSI? or even gigabyte about the problem? Neither have a fix and it seems no one even talks about brands other than Asus.




I have the save issue during Update from 1607->1709 several times. My configuration



BIOS: Latested (MS-7A21)


I would strongly appreciate if Microsoft stop updating my system to 1709 until the issue was fixed!

Security updates are welcome. This must be possible. In this case waiting for the fix is tolerable.




Just the same board and ssd I have and I also meet this issue during updating from 1703 to 1709, this is annoying

A temporary workaround is reboot untill you get the blue screen, press F8 for startup settings.
Then select (7 Disable Driver Signature Enforcement.

This boots the PC. Sometimes it boots after the first reset, sometimes it comes up with the BSOD.