Build is getting failed with error code 2=“null” and 255=“null” in Windows 10 OS

%3CLINGO-SUB%20id%3D%22lingo-sub-1171257%22%20slang%3D%22en-US%22%3EBuild%20is%20getting%20failed%20with%20error%20code%202%3D%E2%80%9Cnull%E2%80%9D%20and%20255%3D%E2%80%9Cnull%E2%80%9D%20in%20Windows%2010%20OS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1171257%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20we%20are%20building%20our%20code%2C%20we%20are%20getting%20the%20build%20error%20such%20as%20255%3D%22null%22%20and%202%3D%22null%22.%3C%2FP%3E%3CP%3EWe%20have%20no%20clue%20how%20to%20fix%20this%20build%20error.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20facing%20this%20build%20error%20after%20we%20migrated%20to%20Windows%2010.%3C%2FP%3E%3CP%3EOur%20Code%20was%20successfully%20built%20when%20we%20used%20Windows%207%20OS.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20see%20the%20build%20error%20in%20the%20below%20mentioned%20log.%3C%2FP%3E%3CP%3EError%3A%3C%2FP%3E%3CPRE%3E2020-02-12%2018%3A19%3A46%20t-58%20WARNING%3A%20Error%3A%20255%3D%22null%22%20when%20executing%20%5BC%3A%5CClones%5CExp%20%0A%5CTSP_VOB%5CBuild%5Cbin%5Cbldcomp.bat%2C%20libVAL%2C%20OSE%5D%0A2020-01-09%2008%3A50%3A55%20t-52%20WARNING%3A%20Error%3A%202%3D%22null%22%20when%20executing%20%0A%5BG%3A%5CTSP_VOB%5CBuild%5Cbin%5Cbldcomp.bat%2C%20libVAL%2C%20OSE%5D%3C%2FPRE%3E%3CP%3EHere%20bldcomp.bat%20is%20the%20batch%20file%20which%20will%20invoke%20the%20make%20file%20the%20make%20file%20inturn%20will%20invoke%20the%20make.exe%2ClibVAL%20is%20the%20component%20to%20be%20build%20and%20the%20OSE%20is%20the%20configuration%20for%20which%20the%20build%20is%20done.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20bldcomp.bat%2C%20libVAL%20and%20OSE%20is%20fed%20to%20the%20processbuilder%20java%20process%20as%20inputs%2C%20while%20the%20build%20is%20going%20on%20the%20build(processbuilder)%20is%20interrupted%20with%20the%20error%20code%202%3D%22null%22%20and%20255%3D%22null%22%3C%2FP%3E%3CP%3EPlease%20see%20the%20environment%20details%20below.%3C%2FP%3E%3CPRE%3ERhapsody%208.0.5%0AJava%20Version%207%0AVisual%20studio%202005%0Agcc%20version%204.2.3%0AWindows%20Version%20%3A%20Windows%2010%20%20%20%20%3C%2FPRE%3E%3CP%3ENote%20%3A%3C%2FP%3E%3CP%3E1)The%20configuration%20can%20be%20of%20any%20specific%20target%20such%20as%20OSE(arm)%2CWinXP(Desktop%20simulation)%2CWinCE%20and%20Lint.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2)The%20Component%20can%20be%20Utilities%2CSIM%2COSAL%2CARCOM%2CFD%2CVAL%2CTRF%2CSVAL%20and%20MSW%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E3)The%20build%20error%20is%20appearing%20in%20any%20component%20and%20in%20any%20configuration%20randomly(meaning%20issue%20place%20is%20not%20definite).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E4)This%20build%20went%20through%20fine%20with%20out%20any%20issues%20on%20Windows%207%20OS%2C%20now%20we%20are%20facing%20this%20build%20errors%20in%20Windows%2010%20OS.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20help%20us%20to%20fix%20this%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%2C%3C%2FP%3E%3CP%3ES.Parthasarathi%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1184076%22%20slang%3D%22en-US%22%3ERe%3A%20Build%20is%20getting%20failed%20with%20error%20code%202%3D%E2%80%9Cnull%E2%80%9D%20and%20255%3D%E2%80%9Cnull%E2%80%9D%20in%20Windows%2010%20OS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1184076%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Ecould%20you%20mention%20which%20Windows%2010%20OS%20build%2Fversion%20are%20you%20using%3F%3CBR%20%2F%3Eit%20could%20also%20be%20related%20to%20VS%202005%20which%20is%2015%20years%20old%20now%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1186204%22%20slang%3D%22en-US%22%3ERe%3A%20Build%20is%20getting%20failed%20with%20error%20code%202%3D%E2%80%9Cnull%E2%80%9D%20and%20255%3D%E2%80%9Cnull%E2%80%9D%20in%20Windows%2010%20OS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1186204%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20find%20the%20Windows%20Specifications%20below.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdition%3A%20Windows%2010%20Enterprise%3C%2FP%3E%3CP%3EVersion%3A%201809%3C%2FP%3E%3CP%3EOS%20build%3A%2017763.1039%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20using%20the%20below%20mentioned%20compilers%20for%20our%20build%20process%3A%3C%2FP%3E%3CP%3Egcc%20version%204.2.3%3C%2FP%3E%3CP%3EVisual%20Studio%202005%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20Make%20utility%20version%20is%20given%20below.%3C%2FP%3E%3CP%3EGNU%20Make%20version%203.79.1%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENote%20%3A%26nbsp%3B%3C%2FP%3E%3CP%3EIts%20a%20blocker%20for%20us%2C%20please%20help%20us%20at%20the%20earliest.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20and%20regards%2C%3C%2FP%3E%3CP%3ES.Parthasarathi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1186325%22%20slang%3D%22en-US%22%3ERe%3A%20Build%20is%20getting%20failed%20with%20error%20code%202%3D%E2%80%9Cnull%E2%80%9D%20and%20255%3D%E2%80%9Cnull%E2%80%9D%20in%20Windows%2010%20OS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1186325%22%20slang%3D%22en-US%22%3EIs%20it%20not%20possible%20to%20use%20a%20more%20recent%20version%20of%20Visual%20Studio%3F%20such%20as%202019%3F%3CBR%20%2F%3Ejust%20give%20it%20a%20try%2C%20there%20is%20high%20chance%20it%20will%20fix%20the%20problem.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1186645%22%20slang%3D%22en-US%22%3ERe%3A%20Build%20is%20getting%20failed%20with%20error%20code%202%3D%E2%80%9Cnull%E2%80%9D%20and%20255%3D%E2%80%9Cnull%E2%80%9D%20in%20Windows%2010%20OS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1186645%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20will%20give%20a%20try%20and%20come%20back.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20and%20regards%2C%3C%2FP%3E%3CP%3ES.Parthasarathi%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1186660%22%20slang%3D%22en-US%22%3ERe%3A%20Build%20is%20getting%20failed%20with%20error%20code%202%3D%E2%80%9Cnull%E2%80%9D%20and%20255%3D%E2%80%9Cnull%E2%80%9D%20in%20Windows%2010%20OS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1186660%22%20slang%3D%22en-US%22%3EGood%20luck%2C%20let%20me%20know%20how%20it%20goes%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi All,

 

When we are building our code, we are getting the build error such as 255="null" and 2="null".

We have no clue how to fix this build error.

 

We are facing this build error after we migrated to Windows 10.

Our Code was successfully built when we used Windows 7 OS.

 

Please see the build error in the below mentioned log.

Error:

2020-02-12 18:19:46 t-58 WARNING: Error: 255="null" when executing [C:\Clones\Exp 
\TSP_VOB\Build\bin\bldcomp.bat, libVAL, OSE]
2020-01-09 08:50:55 t-52 WARNING: Error: 2="null" when executing 
[G:\TSP_VOB\Build\bin\bldcomp.bat, libVAL, OSE]

Here bldcomp.bat is the batch file which will invoke the make file the make file inturn will invoke the make.exe,libVAL is the component to be build and the OSE is the configuration for which the build is done.

 

Here bldcomp.bat, libVAL and OSE is fed to the processbuilder java process as inputs, while the build is going on the build(processbuilder) is interrupted with the error code 2="null" and 255="null"

Please see the environment details below.

Rhapsody 8.0.5
Java Version 7
Visual studio 2005
gcc version 4.2.3
Windows Version : Windows 10    

Note :

1)The configuration can be of any specific target such as OSE(arm),WinXP(Desktop simulation),WinCE and Lint.

 

2)The Component can be Utilities,SIM,OSAL,ARCOM,FD,VAL,TRF,SVAL and MSW

 

3)The build error is appearing in any component and in any configuration randomly(meaning issue place is not definite).

 

4)This build went through fine with out any issues on Windows 7 OS, now we are facing this build errors in Windows 10 OS.

 

Please help us to fix this issue.

 

Thanks in advance,

S.Parthasarathi

5 Replies
Highlighted
Hi,
could you mention which Windows 10 OS build/version are you using?
it could also be related to VS 2005 which is 15 years old now
Highlighted

Hi @HotCakeX

 

Please find the Windows Specifications below.

 

Edition: Windows 10 Enterprise

Version: 1809

OS build: 17763.1039

 

We are using the below mentioned compilers for our build process:

gcc version 4.2.3

Visual Studio 2005

 

The Make utility version is given below.

GNU Make version 3.79.1

 

Note : 

Its a blocker for us, please help us at the earliest.

 

Thanks and regards,

S.Parthasarathi

 

Highlighted
Is it not possible to use a more recent version of Visual Studio? such as 2019?
just give it a try, there is high chance it will fix the problem.
Highlighted

@HotCakeX 

 

We will give a try and come back.

 

Thanks and regards,

S.Parthasarathi