SOLVED

Windows 10 WIP rules and Chromium Edge cannot access Sharepoint Online ERR_BLOCKED_BY_ADMINISTRATOR

%3CLINGO-SUB%20id%3D%22lingo-sub-1673565%22%20slang%3D%22en-US%22%3EWindows%2010%20WIP%20rules%20and%20Chromium%20Edge%20cannot%20access%20Sharepoint%20Online%20ERR_BLOCKED_BY_ADMINISTRATOR%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1673565%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EA%20few%20weeks%20ago%20Sharepoint%20Online%20access%20via%20Edge%20(Chromium)%20browser%20stopped%20working%20from%20our%20AAD%20joined%20%2B%20Intune%20Windows%2010%20(2004)%20computers.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%20size%3D%221%202%203%204%205%206%207%22%3EError%20from%20Edge%3A%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22lia-indent-padding-left-30px%22%3E%3CFONT%20color%3D%22%23FF6600%22%3E%3CSTRONG%3EYou%20don%E2%80%99t%20have%20access%20to%20this%20content%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%20class%3D%22lia-indent-padding-left-30px%22%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23FF6600%22%3ETry%20accessing%20the%20site%20again%20using%20a%20profile%20connected%20to%20your%20work%20or%20school%20account.%20Learn%20more.%20If%20the%20problem%20continues%2C%20contact%20your%20administrator.%3C%2FFONT%3E%3C%2FP%3E%3CP%20class%3D%22lia-indent-padding-left-30px%22%3E%3CBR%20%2F%3E%3CFONT%20size%3D%221%202%203%204%205%206%207%22%20color%3D%22%23FF6600%22%3EERR_BLOCKED_BY_ADMINISTRATOR%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20suspect%20the%20issue%20has%20something%20to%20do%20with%20Windows%20Information%20Protection%20(WIP)%20policy%20because%20of%20the%20error%20message%20and%20since%20IE%20still%20works.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20is%20no%20briefcase%20in%20Edge%20address%20bar.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIntune%20App%20Protection%20have%20and%20Windows%20Information%20Protection%20(WIP)%20policy.%20The%20policy%20have%20both%20WIPMode%20Allow%20and%20Exempt%20policy%20XML%20files%20added.%20It%20have%20worked%20for%20a%20few%20months%20up%20to%20a%20couple%20weeks%20ago.%20We%20have%20not%20touched%20any%20policy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EMsEdge%20-%20WIPMode-Allow%20-%20Enterprise%20AppLocker%20Policy%20File.xml%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EMsEdge%20-%20WIPMode-Exempt%20-%20Enterprise%20AppLocker%20Policy%20File.xml%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%2C%20the%20WIP%20policy%20do%20have%20a%20Network%20Boundary%20for%20Sharepoint%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20image-alt%3D%22Edit%20network%20boundary.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F218747iB47FF56231095BE4%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Edit%20network%20boundary.png%22%20alt%3D%22Edit%20network%20boundary.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1673565%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EEdge%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWIP%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1727704%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20WIP%20rules%20and%20Chromium%20Edge%20cannot%20access%20Sharepoint%20Online%20ERR_BLOCKED_BY_ADMINISTRA%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1727704%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EFYI%3A%20Case%20with%20Microsoft%20Support%20on%20this.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EMy%20affected%20Version%2085.0.564.63%20(Official%20build)%20(64-bit)%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EWhen%20downloading%20version%2084%20everything%20started%20working%20again.%20When%20Edge%20auto-updated%20back%20to%2085.x%20the%20problem%20came%20back%20again.%20Microsoft%20have%20escalated%20the%20case.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1749254%22%20slang%3D%22de-DE%22%3ERe%3A%20Windows%2010%20WIP%20rules%20and%20Chromium%20Edge%20cannot%20access%20Sharepoint%20Online%20ERR_BLOCKED_BY_ADMINISTRA%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1749254%22%20slang%3D%22de-DE%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F134719%22%20target%3D%22_blank%22%3E%40Bj%C3%B6rn%20Lagerwall%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20news%20on%20this%20issue%20we%20have%20the%20same%20problem%20with%20Edge%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1782704%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20WIP%20rules%20and%20Chromium%20Edge%20cannot%20access%20Sharepoint%20Online%20ERR_BLOCKED_BY_ADMINISTRA%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1782704%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F821957%22%20target%3D%22_blank%22%3E%40fbiermaier%3C%2FA%3E%26nbsp%3Bhey%2C%20no%20waiting%20on%20an%20update%20from%20Microsoft%20Support.%20The%20case%20is%20escalated%20but%20I%20cannot%20say%20to%20which%20level.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EProbably%20something%20with%20Applocker%20and%20that%20version%20of%20Edge%20that%20stopped%20working.%20Seeing%20some%20stuff%20in%20applocker%20logs%20I%20sent%20to%20MS%20Support.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1920915%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20WIP%20rules%20and%20Chromium%20Edge%20cannot%20access%20Sharepoint%20Online%20ERR_BLOCKED_BY_ADMINISTRA%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1920915%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F134719%22%20target%3D%22_blank%22%3E%40Bj%C3%B6rn%20Lagerwall%3C%2FA%3E%26nbsp%3BI%20seem%20to%20be%20having%20the%20same%20problem%20when%20I%20try%20to%20reach%20an%20internal%20resource%20all%20of%20a%20sudden%20as%20well.%20Could%20reach%20it%20without%20any%20issues%20before%20using%20Edge.%20Have%20to%20switch%20to%20chorme%20browser%20to%20continue%20operations.%3C%2FP%3E%3CP%3EI'm%20wondering%20if%20this%20could%20be%20caused%20by%20some%20group%20policy%20as%20we%20just%20updated%20the%20admx%20files%20in%20the%20central%20store.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1922739%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20WIP%20rules%20and%20Chromium%20Edge%20cannot%20access%20Sharepoint%20Online%20ERR_BLOCKED_BY_ADMINISTRA%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1922739%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F877414%22%20target%3D%22_blank%22%3E%40Dadoks%3C%2FA%3E%20Hey%2C%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20case%20up%20at%20engineering%20now%20and%20they%20want%20me%20to%20test%20more%20stuff.%20Hopefully%20I%20get%20time%20today%20toi%20test.%20I'll%20post%20my%20findings%20here.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBR%3CBR%20%2F%3EBj%C3%B6rn%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi all,

 

A few weeks ago Sharepoint Online access via Edge (Chromium) browser stopped working from our AAD joined + Intune Windows 10 (2004) computers. 

 

Error from Edge:

 

You don’t have access to this content


Try accessing the site again using a profile connected to your work or school account. Learn more. If the problem continues, contact your administrator.


ERR_BLOCKED_BY_ADMINISTRATOR

 

I suspect the issue has something to do with Windows Information Protection (WIP) policy because of the error message and since IE still works. 

 

There is no briefcase in Edge address bar.

 

Intune App Protection have and Windows Information Protection (WIP) policy. The policy have both WIPMode Allow and Exempt policy XML files added. It have worked for a few months up to a couple weeks ago. We have not touched any policy.

 

MsEdge - WIPMode-Allow - Enterprise AppLocker Policy File.xml

MsEdge - WIPMode-Exempt - Enterprise AppLocker Policy File.xml

 

Also, the WIP policy do have a Network Boundary for Sharepoint

Edit network boundary.png

 

 

 

 

 

 

 

 

 

Any suggestions?

 

Thanks!

 

 

8 Replies

FYI: Case with Microsoft Support on this.

 

My affected Version 85.0.564.63 (Official build) (64-bit) 

 

When downloading version 84 everything started working again. When Edge auto-updated back to 85.x the problem came back again. Microsoft have escalated the case.

@Björn Lagerwall 

Any news on this issue we have the same problem with Edge

@fbiermaier hey, no waiting on an update from Microsoft Support. The case is escalated but I cannot say to which level. 


Probably something with Applocker and that version of Edge that stopped working. Seeing some stuff in applocker logs I sent to MS Support.

 

 

@Björn Lagerwall I seem to be having the same problem when I try to reach an internal resource all of a sudden as well. Could reach it without any issues before using Edge. Have to switch to chorme browser to continue operations.

I'm wondering if this could be caused by some group policy as we just updated the admx files in the central store.

@Dadoks Hey, 

I have the case up at engineering now and they want me to test more stuff. Hopefully I get time today toi test. I'll post my findings here.

 

BR
Björn 

@Björn Lagerwall Please let us know what you results are. I also noticed that the issue seems to be particular to systems that have recieved the Win10 20H2 update. Hope that helps you narrow down and simulate the cause.

@Dadoks yeah will post here. Case is still ongoing. Apparently Edge Team and WIP Team now are looking into the issue. 

 

Using an older version of Edge (ver 85 if I recall correctly) it started to work again. But the Edge auto-updated and it stopped once again. 

 

Hopefully, they find it soon, granted complicated issue, bit still a long running case.

Best Response confirmed by Björn Lagerwall (Contributor)
Solution
Hi all,

Got an suggestion from Microsoft Support to change the corporate identity in WIP policy from tenant name to our AD name and it worked!

See below explanation from Microsoft Support.


Resolution: We made a change in the Edge 85-86 to check the domain of the profile's AAD identity instead of automatically treating all AAD identities as a work profile.
In your case, the corporate identity was contoso.onmicrosoft.com, and your Work profile was contoso.com. We confirmed by checking edge://edge-dlp-internals/#NetworkIsolation-policies and seeing EnterpriseNetworkDomainNames we blank. After making the change of the corporate identity to contoso.com, you can now access your SharePoint site.