Cannot create .net5 or .net6 project

Occasional Contributor

I know this question has been asked, but I have not been able to find a clear solution.

 

On my development computer, .net SDKs 5.0.300, 5.0.400, 5.0402, and 6.0.101 are installed.

Using newly installed Visual Studio 2022, "Create New Project" brings up a screen with template choices.

Choosing language=Visual Basic, platform=All Platforms, and Project type=any (tried all separately), there is no template available for .net 5 or .net 6.

 

What am I missing?

 

Help most appreciated.

 

Thank you.

2 Replies

@GreatDaneMusic 

Which version of OS you are using?

When you installed Visual Studio, did you selected Web-Application in .NET Core?

Because I recently installed Windows 11 and also installed VS 2022, it worked find for me, when creating new Project in VS 2022, at last point , VS asks, which Version of .NET you want to use.

I can see option to choose .NET 5 and .NET 6

versions-net core.png

You can check Visual Studio versions here and .NET Core

Hi @GreatDaneMusic,

Thanks for posting your issue here.

However this platform is used for how-to discussions and sharing best practices for building any app with .NET.Since your issue is a technical question, welcome to post it in Microsoft Q&A forum, the support team and communities on Microsoft Q&A will help you for any technical questions.
Besides, it will be appreciated if you can share it here once you post this technical question Microsoft Q&A.
Best Regards,
Lan Huang