Viva Learning SharePoint Content not Showing Up

New Contributor

I have a tenant where I have enabled Viva Learning and SharePoint as a content store. I have gone to the site and setup the Folder URL in the Learning App Content Repository. The content in the folder will not appear in Viva Learning although the provider does show up as a search selection but no content will return.

 

I have tried shared URL's and current access only URL's with no success. I have this up on other tenants with no issue. My gut tells me there is a permissions issue somewhere but I cannot find where that might be.

 

Has anyone experienced this and found a solution?

 

Thanks.

18 Replies
I have the exact same issue on our tenant. I am a Global Admin and added myself as a Knowledge Administrator for good measure. Still no SharePoint content store available within Teams.
Other people are reporting delays so this could be the issue - see below. I'll give it another day or two. https://techcommunity.microsoft.com/t5/viva-learning/add-organization-s-content/td-p/3167442

Hi @Chris_Canning, where you able to make the content appear in Viva Learning? We are currently experiencing the same issue. I waited 2 days and the Permissions tab appeared in Settings. Nevertheless, even if the company name appear as provider no content is available in the App.

Any advice is very welcome :)

FYI, 2 months later and I still don't have the admin options or the SharePoint content store setting... I even raised a service request with no effect...

We are having the exact same issue. Anyone have a known fix for this?

@DevonTrainer 

 

It has all been a bit weird tbh. A few things have happened. I forced a reindex on the document library containing the material and this originally got things to start showing in Viva Learning. However, new documents added to the repository were not showing up and I kind of moved on to other things. Then someone else added a new document to the repository so I decided to check and all the files had begun showing up. I was getting ready to roll it out to the organization at this point and then all of a sudden everything disappeared from Viva Learning again. I deleted and recreated my Learning Repository link and as of now everything is working and loading again.

 

All that said my confidence is not currently high on its stability . . .

See reply to DevonTrainer
See Reply to DevonTrainer
Chris, are you still waiting for SP content to appear in Viva Learning? I'm in the same boat - we waited about a week, no joy, so removed the connection in the Learning App Content Repository, and added two new connections to folders with only a hand full of low-size office docs. Day 2, still waiting. On other tenancies, they appeared in about a day.

@Chris_Canning I ran into the exact same problem.  I setup everything up per the instructions and my instruction showed up as a content source in Viva Learning, but there was no content.  I tried to re-index as someone mentioned, but also didn't solve the problem. 

 

Today, I started over and followed this video step by step (https://www.youtube.com/watch?v=JftHvMtnNA8).  Within an hour, my content was there.

 

There are only 2 things I can see that this process did differently.  First, I setup the SP page that would host the content as a communication page.  Previously, I was using a Teams page.  I don't know if that made a difference, but that was one that I did differently.  I also setup my columns exactly as he did which included a Thumbnail column.

 

Lastly, I add read permissions to all internal users to the SP page with the content.  Again, I don't know if this made a difference, but it is one difference in the steps.

 

I can't say whether this will keep working, but it did initially fix the issue for me.

Hi @KevinMFarren, thank you for sharing the video and instructions. I followed them step by step but still no content is appearing in VivaLearning for us. I have now tried to reindex the the document library containing the material as @Chris_Canning suggested above and I am currently waiting to see if the content will show up in a few days.

 

I will write again if I manage to identify the problem and the solution :)

I managed to sort out my issues:
1. I created a Communication Site instead of a Teams Site. Apparently Viva Learning does not work with Communication Sites.
2. I was using MS Teams on Preview mode. The "SharePoint content store" option in the settings is not available on the preview client. Once I switched to a Teams Site, the option was available on the Monthly channel client and on Teams online

Hi @mandreou, thanks for your update. I wanted to share our updates with everyone too:

  • We are now seeing a similar issue in a CDX tenant as well - the SP Learning App Content Repo is configured on a comms site, and there is no preview or early release selected in Teams or the overall tenancy. Like your earlier issues, SharePoint is not even available as an option to check Permissions to the Learning App Repo from Viva Learning Settings in Teams.
  • In our client's production tenancy, we have now been waiting a full month, and the issue is exactly as it has been since early May -
    • Viva Learning SP Learning App repo was also configured in an SP comms site.
    • Preview mode is not configured in Teams.
    • We can successfully check SP permissions from the Viva Learning Teams app.
    • SP appears as a content provider from the Learning App in Teams, but no content appears.  It looks like it is trying to surface content or connect to content source for a couple of seconds, and then errors out:

jiggerbyte_0-1654501660212.png

    • We have even escalated to MSFT Fastrack and our Viva Blackbelt connection, who have confirmed that we have setup SP for Viva Learning perfectly, but are also confused as to why this is not working, and have yet to share a workaround or fix.

@VelSom, MSFT confirmed that we shouldn't have to rely on indexing, as the Learning App Repo directly points to the content.

If anyone else out there manages to find any other workarounds to crack this issue, I very much look forward to hearing all about it.  We are all losing confidence in the platform!

We have the same issues plus an issue with our cornerstone content which is weird. 

 

Fo SharePoint content we have it on a Comms site with an office group having the required permissions for read to the site that has the list that has the content and the list pointing to the content. 

 

Still nothing shows up yet it worked on our Dev tenant. 

 

For the cornerstone issue it looks teams desktop client related. 

As all the course catalog shows up on web / mobile editions and on the desktop client on certain PC's yet on others it only shows a small number of courses. 

Tried totally uninstalling teams and clearing and artifacts. Including remove the viva learning app. Restarting the machine and reinstalling teams. Still get the same issue. 

 

Woking with Microsoft on the issues but so far not a lot of luck with anything we have tried. 

@Philip Worrell - we found the root cause!!! Looks like MS have updated the permission framework - permission settings now need to be configured using M365 groups, NOT the default SP permission groups.

Weeks before this article was released, it appears they had changed settings behind the scene, so unless your SP libraries' permissions were configured using M365 groups, nothing would surface.  https://docs.microsoft.com/en-us/viva/learning/configure-sharepoint-content-source#permissions 

Found our problem - similar
We had configured access with a Microsoft group on the content site.
However, what we did wrong, we nested the group inside the SP visitors group on the site.
We had to put the group up a level and then content started to appear.

We still have an odd problem with Cornerstone courses not showing up, though we think we are closed to fixing the issue and have a work around though a painful one.

With this one the courses were mostly published in cornerstone as in UK English.
The Teams client was set to the US English.
The full list would only appear when changing the teams client to UK English.
Crazy filter. Still open with Microsoft to resolve that.

I work within the EDU Soultion Area. I have been trying for weeks to accomplish this same task; however, my blocker has been determining who, within our team, has Global Admin privileges. How can I figure out who has Global Admin permissions in the EDU tenant?

Hi @Amanda_Wilholt 

Go to your office 365 admin center - Roles - Global administrator - Assigned.