Universal Print issues with printers installed

Copper Contributor

Hey,  I am encountering some issues I cannot resolve.

For some people, the shared printer from universal printing stops working - no apparent reason.

Removing the printer and adding it again has helped - for a while.  But on my surface pro, for example - You remove the printer, but it still shows up as being installed when you search to install it again.

Whatever you do, the work or school search shows the deleted printer is still installed, so it is impossible to add it again.

To get around that, I previously created a new printer, but it isn't a good solution.  Anyone experienced a similar thing?

17 Replies

@marknich - Best option is to reach out to Microsoft Support (use the links on Universal Print portal). You should get direct help from someone.


You can also create a Windows Feedback. This will be looked at (no definite priority/timeline) by the Print team at Microsoft.


To create Windows Feedback follow the steps below:

  1. On Windows device, launch Feedback Hub app
  2. Click on Report a Problem
  3. Enter title and as much detail as you can (with repro steps)
  4. Choose category as Problem -> Devices and Drivers -> Print
  5. Click on Make new bug
  6. Under Add more details, click on Recreate my problem -> Start Recording
  7. Select both checkboxes (Include data about Print (default) and Include screenshots)
  8. Go through each step in your repro
  9. Come back to feedback hub and stop recording
  10. Click on Submit
  11. After clicking, you will get an option to Share. Click on that, copy the URL and share as response to this thread.




@marknich Did you ever figure out a fix?


I've got a similar issue on my laptop and noticed the same issue on another machine.

If you want to print something, the cloud printer does not show as an available printer, but when you go to add a new printer it shows the cloud printer as installed with no option to re-install


I stopped using Microsoft's deployment methods to automatically install printers via universal print.
That is when things would get messed up - unable to uninstall printers and reinstall them, printer would stop working and be unremovable.


If I let the users install their own printers, there would be much less issues.

I've run into this issue and still looking for a solution - there is no alternative when you need to point your cloud printer to something like Business Central that needs it.

@yaseen777 - sorry to hear that you are facing this issue. Can you explore reaching out to the Support?


This may be a known issue with Windows 11 21H2 and was fixed in 22H2. You can try updating to 22H2 and see if this issue is resolved.


One caveat - if there is a printer which is already in a state where its not installed, but adding it shows that its already installed, then it will need to be cleaned-up and Microsoft support can help with that.

Hi - 


The issue is that the printers are in a partially installed state. Go to Settings -> Bluetooth and Devices -> Devices (not Printers) and you should see the printers listed there. Remove them there and restart the system. You should now be able to re-install the printer. 


As for why the printers stop working in the first place, please open a Support ticket with Microsoft CSS Universal Print support team, and we can take a look. 



Thanks for your input, That is an easy fix and easily done, it was the first thing I tried.  With support we had to run some tools, disable all the intune security and modify the registry to remove the printers.  Support have no idea why the printers stop working. @Philip_Demaree 

You can also run:

in the RUN box to get the old control panel back. Then Right Click Remove Device.

Verify its also removed from the new Print Settings.
thanks we tried all these kinds of fixes, but only using registry hacks would get rid of the printers. Part of the issue, I am sure, is the microsoft baseline security profile that is applied to these devices. You have to disable the intune policies before you start.

Dear @m_nicholls, Might I ask you what Registry hacks you have performed? I'm experiencing the issue at my company as well in where the printer shows that it's installed but cannot be selected upon trying to send a document to a printer. Regardless of the application. Removing the printer is impossible, either via the Device Manager or Printers and Devices. Leaving me with no choice but to open up an incident.


The Device Manager does not show the printer. The old environment of Printers and Devices shows that the Printer has been categorized as a Cloud Printer with the Status: Driver is Unavailable. It's also set below "Unspecified" devices.


It has been rather though getting through the first-line employees at Microsoft and they are not being helpful. I believe I've had 4 engineers so far and I'm at my wit's end. Hence my question. Can you explain to me in what location you had removed the Universal Print Registry keys that allowed you to make the printer installable again? That would be much appreciated. 

this is what I do:
1. Download psexec from
2. From an elevated command prompt, launch regedit
psexec -i -d -s c:\windows\regedit.exe
3. Navigate to the following registry key for the User SID -
Computer\<SID>\Software\Microsoft\Device Association Framework\Store
4. Under the MCP#<guid> key, open the sub-GUID keys and find the key 000C
5. Select the “Default” value, right click, and select “Modify” from the menu to open the value in an edit box
6. On the right-hand side of the window you should see the ASCII equivalent of the binary string as https:\ \printers<ShareID>.
7. Match the Share ID portion of the string with ShareID of the printer listed in UP Portal. If they match, you have the correct MCP#key.
8. Delete the MCP#key
9. Navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Device\AssociationService\State\Store and delete the MCP key with the same name as the previous key.
10. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SWD\PRINTENUM and find the GUID key that references the printer’s Friendly Name (if it exists)
11. Locate the ContainerID value and find the IPP-GUID key that has the same ContainerID
12. Delete both keys.
but first, I have to remove the device from intune security policies before this will work
Hi Marknich,
To resolve this issue, open the systems settings and under Bluetooth you will see the Universal Print Printer in question.
Click the three dots (...) and select remove.
Go back and try adding the printer again, and it should work.

Let me know your feedback.
best response confirmed by marknich (Copper Contributor)

@I-Am-Will Hi, the issue was resolved when we migrated everyone from 21H2 to 22H2, the problem hasn't come back after that.


The fix you mentioned didn't work on 21H2, but can be useful on 22H2

@marknich Unfortunately we are on 23H2 and there seems to be no way around this, I have successfully removed the device a couple of times, no solution.

Another concern is that this users have access to other printers and they work seamlessly.

@AnointedOnyeacho - have you looked at the steps from @m_nicholls in the chat above? If that does not work, I recommend reaching out to Microsoft Support.

I haven't had this issue since leaving 21H2, but microsoft support told me to delete the universal printer and recreate it, if it was having issues.
1 best response

Accepted Solutions
best response confirmed by marknich (Copper Contributor)

@I-Am-Will Hi, the issue was resolved when we migrated everyone from 21H2 to 22H2, the problem hasn't come back after that.


The fix you mentioned didn't work on 21H2, but can be useful on 22H2

View solution in original post