Universal Print Conector Error while registerting

Occasional Contributor

Hi All, 


I got an error while registering the Universal Print Connector. It says: Error occured while registering the connector. Error code BadRequest: Error message: Connector Device already exists. 


To me this seems that is somewhat worked but not fully. When I look into the Azure Portal it says the connector is there, but health status is unknown. 


I have checked all the accounts I am currently working with have the licenses added to them.


There is no option to remove this connector and redo it from there, what can I do to get it working so we can test it out? 


Thanks in advance!


Kind Regards, 

Johny de Koning

4 Replies
best response confirmed by Johny_de_Koning (Occasional Contributor)



Hi Johny,


Sorry to hear you're having trouble registering your Connector! The best thing to try is:

  1. Follow these instructions to install the Universal Print PowerShell module
  2. Make sure you're using the latest Connector version
  3. Get the ID of your Connector by clicking on it in the Azure Portal:

  4. Remove the Connector by running the Remove-UPConnector cmdlet:
    Remove-UPConnector <connector id>​
  5. Register the Connector again.

If you're still unable to register your Connector after removing it and making sure you have the latest version installed, please contact support so they can collect logs and fully diagnose your issue.



Hi Braeden, 


Thank you for the tips this has solved the issue. I could register the connector now properly and I have added some printers. I can now take a look at the product and see how it works.


Thanks again!


Kind Regards, 

Johny de Koning

@Braeden_Petruk_MSFT i have a similar issue but am unable to deregister the connector using powershell, any other suggestions?

@intpro420 Are you encountering an error while attempting to unregister the Connector?


If you can share details via PM or by opening a support ticket we might be able to help you solve that problem.