Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Not able to unregister a printer

Copper Contributor

Hello,

We have been able to successfully use Universal Printer in a trial Azure subscription. That subscription is gone and no longer exists. 

Now we have a new Pay to Go Azure subscription and we are trying to add the same printer again via the Universal Printer Connector. 


What happens is the existing printer shows up in the Universal Printer as registered already after logging on and there is no need to re-register it. The universal connector shows up in the Azure AD connector but it does not list the printer. 

 

How can we "unregister" the printer via the Universal Printer Connector so we can register it again. We cannot do from the Azure subscription because there is no printer. 

Uninstalling the universal printer connector and removing the connector from Azure AD via PowerShell does not resolve the issue.

In event log file we see hundreds of these trace events:
Http request failed for this IPP request with response:
StatusCode: 403, ReasonPhrase: 'Forbidden', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
{
mise-correlation-id: e8b8bd20-68a7-4c62-95a8-08d82b61eaba
X-Content-Type-Options: nosniff
MS-CV: St6UapNEbEyXOiAb.0
X-Cache: CONFIG_NOCACHE
X-MSEdge-Ref: Ref A: 2D509EF7A81341CFBCF2487A229FC738 Ref B: AMS231032603005 Ref C: 2023-02-10T10:55:44Z
Cache-Control: no-store, must-revalidate, no-cache, max-age=0
Date: Fri, 10 Feb 2023 10:55:44 GMT
Set-Cookie: UserRegion=europe; path=/; samesite=lax; httponly
Content-Length: 0
}

Method <SendIppRequestAsync>b__0 (Operation name: GetJobs is not being retried for HTTP error Forbidden
Retry Loop Completed: False
Retry Count: 0
Callstack:
ProxyLibrary.RetryHandler+<RetryAsync>d__3`1
ProxyLibrary.IPPRequestSender+<>c__DisplayClass20_0+<<SendIppRequestAsync>b__0>d
ProxyLibrary.IPPRequestSender+<SendIppRequestAsync>d__24

Exception:
ProxyLibrary.UPServiceException: Exception of type 'ProxyLibrary.UPServiceException' was thrown.


There is no event ID 8. 


Thank you. 

Kindest regards,
Marga

3 Replies
Hi Marga,

Please help me understand, did you try to unregister the printer using the Universal Print Azure Portal? https://learn.microsoft.com/en-us/universal-print/portal/register-unregister-printers.

Thanks.

@Issa Khoury 

hi, same issue, i unshared a Konica Minolta device through universal print then unregistered the device. I have now tried to re-register but get an error saying the device is still registered ?

i have also tried to register the device to another universal print tenant with no issues ?

@Ian_Wallace2020 and @Melsbergmans 

It seems that the printer is in a bad state because of the Azure subscription change.

 

Please file a support ticket so the Universal Print team can help you with this.