Incompatible printer drivers with Universal Print Connector


Hi all,


If you are encountering issues with a particular OEM printer driver on the Windows PC hosting the Connector, please post a comment with the driver name.

Possible results due to compatibility issues

  • Unable to register the printer to Universal Print
  • Missing basic print options, such as
    • paper size / paper type
    • Color / grayscale / monochrome
    • Duplex
    • N-up
    • Stapling
    • Hole punch
    • etc.

Note: Advance functionality such as prompting user for account ID or PIN or watermark, etc. are not supported at this moment.


This will help us work with the OEM to investigate the problem.



16 Replies



I have been trying to print to A3 with some of our larger sharp machines but I am limited to A4 or Letter with the provided Sharp drivers. 

The screenshot below with the entries highlighted are the drivers I have had this limitation with. In addition, I was only able to get stapling to work if I use the 6070v driver.

Lexmark seem to have a much better driver as all of the features are available!



@JoeMatthews, thanks for reporting this issue.  Are you using the latest version (v1.0) of the Connector software (  If so, please open a support case so we can better work with you to identify the issue.


We've fixed a number of issues and definitely recommend customers to use the most recent Connector for the best experience.


Many thanks @Jimmy_Wu yes we are.

We will raise a ticket.



I'm having problems with the Xerox Global Print Driver PS v.5.733.11, however only with one printer, the Versalink C405. Universal Print is showing it as a Phaser with only grayscale and single-side capabilities, when it is a color, duplex printer. The Xerox C70 copiers that we have also deployed with Universal Print, however, appear to have most of the expected features, even though it's the same driver.

I managed to fix the problem by manually updating the Print Connector to version 1.10.7541.40729. Now the Versalink printer is showing the correct feature set.


Even though the previous version I had installed (1.4 I think) had the "auto update" option enabled, it was not updating and the error log was filled with messages about the update being "blocked". For those who are wanting to manually update their connectors as well, you need to stop the "Print Connector" service, otherwise the installer will fail.

@Stephan Swinford thanks for the feedback! Latest version has not been scheduled for auto-update yet - that's why you had to manually update it. We will be publishing the latest update via auto-update soon.





@Jimmy_Wu We are unable to register Xerox VersaLink C7020 with driver V4 PCL6, registration fails. We are using connector version 1.14.7564


Anna Andersen


We are seeing issues with our clients Xerox Fleets.

The users select colour for their printing, but it always comes out as Black and White, even if the printers "default" inside Universal Print is set for color.



ApeosPort-IV C4475
ApeosPort-IV C2275
ApeosPort-V C4475
ApeosPort-V C2275
ApeosPort-V C2276
Fuji Xerox VI C2271


Drivers used:



The only "fix" so far is to manually install the real driver on each users machine and change the installed Cloud Printer to use the real driver.

For the 200 seats they have, this is a major IT headache.

@KamiMcleod, we know that there may be compatibility issues with some printer drivers with the Universal Print connector software since there's a wide variety of driver implementations and customization.  If possible, I recommend opening a case with Microsoft Support for further investigate where the compatibility problem may be.




@Jimmy_Wu I am currently having issues with the Fuji Xerox ApeosPort-VI C3370 printer and some of the finishing options are not coming through, including hole punch and folding options. I have tested with the Xerox GPD PCL6 driver but it does not appear that those attributes are being converted successfully for use with Universal Print.


I do currently have a ticket open with Microsoft Support about this, but I thought I'd write this post up as well just in case. I've tried talking to FX Support but so far they have simply said Universal Print is not supported.

We have issues with Sharp MX-3070V & MX-5070N. The connector does not read the possible paper sizes e.g. can see A4, but not A3. Connector is on latest version (1.34.7683.23618). Also OEM Drivers latest PCL6 version.

Any tips?
Thank you in advance!

@Luka Mestrovic Universal Print connector expects drivers to be conformant with Windows Print Schema. If print drivers define standard attributes and values in custom namespace then connector may not be able to translate them. It depends on how the driver is written. For more details checkout - Print options for printers registered via connector | Microsoft Docs.


Having said that, our support team can work with you to help in case anything can be done. Please open a support case via Azure Support portal.

@AndrewSwan - please look at my response to @Luka Mestrovic. How drivers are translated to Universal Print protocol depends a lot on the way driver is authored. Please work with your printer manufacturer to see if there is a better driver provided that may work with Universal Print.



Thank you for the feedback!

I have checked the documentation and compared the local PCPT vs Service Attributes and Service PDC and I find it very confusing that local PCPT is consistent in service declaration and should be recognized by the connector as the options under are listed in docs as supported, but it does not.


For example A4 (works) vs A3 that does not work.

Namespaces are defined as following:


Local PCTPService AttributesService PDC
      <psf:Option name="psk:ISOA4">
        <psf:Property name="psk:DisplayName">
          <psf:Value xsi:type="xsd:string">A4</psf:Value>
        <psf:ScoredProperty name="psk:MediaSizeWidth">
          <psf:Value xsi:type="xsd:integer">210000</psf:Value>
        <psf:ScoredProperty name="psk:MediaSizeHeight">
          <psf:Value xsi:type="xsd:integer">297000</psf:Value>
Attribute media-supported - Multiple Values:
<psk:ISOA4 psf2:psftype="Option" psf2:default="false">
 <psk:MediaSizeWidth psf2:psftype="ScoredProperty" xsi:type="xsd:integer">210000</psk:MediaSizeWidth>
 <psk:MediaSizeHeight psf2:psftype="ScoredProperty" xsi:type="xsd:integer">297000</psk:MediaSizeHeight>    <psk12:PortraitImageableSize psf2:psftype="Property" xsi:type="psf2:ImageableAreaType">2120,2120,205760,292760</psk12:PortraitImageableSize>
<psf:Option name="psk:ISOA3">
        <psf:Property name="psk:DisplayName">
          <psf:Value xsi:type="xsd:string">A3</psf:Value>
        <psf:ScoredProperty name="psk:MediaSizeWidth">
          <psf:Value xsi:type="xsd:integer">297000</psf:Value>
        <psf:ScoredProperty name="psk:MediaSizeHeight">
          <psf:Value xsi:type="xsd:integer">420000</psf:Value>
Attribute media-supported - Multiple Values:

Had something been wrong the connector would not recognize A4 to start with. A3 and other are declared correctly.


I will contact support!

Kind regards,



@Luka Mestrovic recommend you to reach out to support via Azure Support portal. They will be able to collect the required information and work with engineering team to help you with the issue.


Jimmy, I am having some issues with Konica Minolta's Universal Printer Driver v4. The issue relates to missing options for hole punching and folding finishing options,  stapling is okay. The local.pdc generated for the driver/printer appears to pick up the punching function but from what I can see this does not appear to translate to the Service.pdc or ServiceAttributes files. Essentially, end user can't access either function. I have tried using the KM device specific driver on the connector but this is actually worse as it also then drops stapling. Is this the sort of thing you were referring to below in relation to compatibility issues?