Can not add members to the printer and sharing keeps failing

Copper Contributor

Well I onboarded a printer yesterday and adding members and sharing the printer worked quite well.


However today I onboarded another printer and somehow adding members is grayed out and if I try to share the printer it keeps failing (without any helpful message).


Anyone else having this issue or knows what I am missing?

5 Replies

@Weatherlights have you tried again and were you able to register the second printer? If not, I recommend reaching out to Microsoft Support using either of the following (based on your Support plan with Microsoft):

  1. Windows Support for Business
  2. Azure Support
  3. Services Hub

@Weatherlights Hi I am experiencing the same issue with one printer, I have added and shared several printer both before and after the printer with the issue. I have also tried to unregister the printer but this ends up in a page showing "We can't reach the service at the moment. Please try again later." Tried for three days now.



@Jan_E950 / @Weatherlights we found a related issue in our setup and wanted to check if it may be a same problem on your end.


Do you have any other printer shared already with the same name? 


Universal Printer requires the share names to be unique. Can you try using a different name and see if it works?

@Saurabh_Bansal Hi, we had the same printer shared on another connector, and I removed share, and unregistered the printer, installed it on another connector, registered the printer on the new connector, now we cannot share the printer (also tried different share names), I was also thinking that I could unregister the printer and register it with a new name, but I am not able to unregister the printer as described in the earlier post.

@Saurabh_Bansal Hey


Yes another printer was working fine and it was the only printer I added. Sadly the affected printer is now out of order anyway but another printer was working fine.