When printing to a universal print queue, every job errors out

%3CLINGO-SUB%20id%3D%22lingo-sub-1454761%22%20slang%3D%22en-US%22%3EWhen%20printing%20to%20a%20universal%20print%20queue%2C%20every%20job%20errors%20out%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1454761%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20an%20Azure%20server%20hosting%20print%20queues.%26nbsp%3B%20The%20PQ's%20use%20an%20FQDN%20on%20the%20port.%26nbsp%3B%20The%20port%20is%20set%20to%20RAW%209100.%26nbsp%3B%20I've%20using%20HP%20MFD's%20and%20Xerox%20MDF's.%26nbsp%3B%20These%20print%20queues%20spool%20jobs%20without%20any%20issues%20directly%20from%20the%20server%20or%20mapped%20off%20the%20server%20to%20my%20client.%26nbsp%3B%20I've%20got%20a%20connector%20installed%20which%20discovered%20the%20PQ's.%26nbsp%3B%20These%20PQ's%20are%20registered%20on%20the%20connecter%20and%20are%20available%20in%20Azure%20%2F%20Universal%20Print.%26nbsp%3B%20I've%20shared%20the%20PQ's%20and%20added%20permissions.%26nbsp%3B%20I%20can%20search%20from%20my%20Win%20client%20and%20find%20the%20cloud%20PQ's.%26nbsp%3B%20I%20can%20add%20them%20without%20any%20issues.%26nbsp%3B%20It%20appears%20print%20jobs%20spool%20from%20the%20client's%20PQ's%20but%20once%20the%20file%20size%20completes%20the%20job%20hangs%20and%20eventually%20displays%20an%20error.%26nbsp%3B%20It%20appears%20it%20never%20get's%20to%20the%20server.%26nbsp%3B%20Nothing%20in%20the%20event%20log%20on%20the%20server%20either.%26nbsp%3B%20I've%20unregistered%20PQ's%20and%20changed%20the%20port%20form%20FQDN%20to%20IP%20and%20no%20change.%26nbsp%3B%20These%20PQ's%20work%20fine%20just%20not%20with%20Universal%20Print.%26nbsp%3B%20I've%20attached%20some%20print%20queue%20screen%20shots.%26nbsp%3B%20What%20else%20can%20I%20modify%20in%20Universal%20Print%20to%20complete%20a%20print%20job%3F%3F%26nbsp%3B%20I%20can%20attach%20the%20connector%20diag%20of%20the%20printer%20if%20needed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1482227%22%20slang%3D%22en-US%22%3ERe%3A%20When%20printing%20to%20a%20universal%20print%20queue%2C%20every%20job%20errors%20out%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1482227%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F623190%22%20target%3D%22_blank%22%3E%40larry900%3C%2FA%3E%2C%26nbsp%3Bif%20you%20are%20still%20having%20problems%2C%26nbsp%3B%3CSPAN%3EI%20recommend%20opening%20a%20support%20ticket%20with%20Microsoft%20CSS%20so%20they%20can%20help%20you%20troubleshoot%20the%20problem.%26nbsp%3B%20You%20can%20file%20a%20support%20ticket%20at%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Fupsupport-azureportal%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Fupsupport-azureportal%3C%2FA%3E%3CSPAN%3E.%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EIf%20you%20don't%20have%20an%20Azure%20subscription%20then%20the%20Universal%20Print%20option%20will%20not%20be%20shown.%20In%20that%20case%20open%20a%20Azure%20support%20case%20and%20in%20the%20description%20specify%20that%20your%20case%20needs%20to%20be%20routed%20to%20the%20Universal%20Print%20team.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERegards%2C%3C%2FP%3E%0A%3CP%3EJimmy%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1487328%22%20slang%3D%22en-US%22%3ERe%3A%20When%20printing%20to%20a%20universal%20print%20queue%2C%20every%20job%20errors%20out%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1487328%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F70523%22%20target%3D%22_blank%22%3E%40Jimmy%20Wu%3C%2FA%3E%26nbsp%3BI'm%20having%20what%20appears%20to%20be%20the%20same%20issue.%26nbsp%3B%20We%20opened%20a%20ticket%20with%20Azure%20support%20and%20they%20couldn't%20identify%20the%20issue.%26nbsp%3B%20The%20end%20result%20being%20we%20were%20told%20there%20was%20no%20more%20support%20available%20for%20this%20preview%20feature%20and%20the%20ticket%20had%20to%20be%20archived.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1492984%22%20slang%3D%22en-US%22%3ERe%3A%20When%20printing%20to%20a%20universal%20print%20queue%2C%20every%20job%20errors%20out%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1492984%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20were%20able%20to%20get%20this%20working%20with%20help%20from%20the%20Universal%20Print%20support%20team.%26nbsp%3B%20Thank%20you.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1604035%22%20slang%3D%22en-US%22%3ERe%3A%20When%20printing%20to%20a%20universal%20print%20queue%2C%20every%20job%20errors%20out%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1604035%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F709408%22%20target%3D%22_blank%22%3E%40sd27ryan%3C%2FA%3E%26nbsp%3BHI%2C%20I%20had%20similar%20problems%2C%20what%20was%20the%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1604047%22%20slang%3D%22en-US%22%3ERe%3A%20When%20printing%20to%20a%20universal%20print%20queue%2C%20every%20job%20errors%20out%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1604047%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F12589%22%20target%3D%22_blank%22%3E%40Christophe%20Barneaud%3C%2FA%3E%26nbsp%3BAccount%20impersonation%20was%20enabled%20by%20default%20in%20the%20client%20we%20used%20to%20install.%26nbsp%3B%20It%20has%20supposedly%20been%20disabled%20in%20the%20newer%20versions%20of%20the%20client.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I have an Azure server hosting print queues.  The PQ's use an FQDN on the port.  The port is set to RAW 9100.  I've using HP MFD's and Xerox MDF's.  These print queues spool jobs without any issues directly from the server or mapped off the server to my client.  I've got a connector installed which discovered the PQ's.  These PQ's are registered on the connecter and are available in Azure / Universal Print.  I've shared the PQ's and added permissions.  I can search from my Win client and find the cloud PQ's.  I can add them without any issues.  It appears print jobs spool from the client's PQ's but once the file size completes the job hangs and eventually displays an error.  It appears it never get's to the server.  Nothing in the event log on the server either.  I've unregistered PQ's and changed the port form FQDN to IP and no change.  These PQ's work fine just not with Universal Print.  I've attached some print queue screen shots.  What else can I modify in Universal Print to complete a print job??  I can attach the connector diag of the printer if needed.

5 Replies

@larry900, if you are still having problems, I recommend opening a support ticket with Microsoft CSS so they can help you troubleshoot the problem.  You can file a support ticket at https://aka.ms/upsupport-azureportal.  If you don't have an Azure subscription then the Universal Print option will not be shown. In that case open a Azure support case and in the description specify that your case needs to be routed to the Universal Print team.

 

Regards,

Jimmy

@Jimmy_Wu I'm having what appears to be the same issue.  We opened a ticket with Azure support and they couldn't identify the issue.  The end result being we were told there was no more support available for this preview feature and the ticket had to be archived.

We were able to get this working with help from the Universal Print support team.  Thank you.

@sd27ryan HI, I had similar problems, what was the issue?

@Christophe Barneaud Account impersonation was enabled by default in the client we used to install.  It has supposedly been disabled in the newer versions of the client.