Universal Print Connector - You don't have access..

%3CLINGO-SUB%20id%3D%22lingo-sub-1874024%22%20slang%3D%22en-US%22%3EUniversal%20Print%20Connector%20-%20You%20don't%20have%20access..%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1874024%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20attempting%20to%20install%20the%20Universal%20Print%20Connector%20on%20my%20AAD%20Joined%20laptop.%3C%2FP%3E%3CP%3EAfter%20successfully%20logging%20in%20under%20my%20tenant's%20Global%20Admin%20account%2C%20entering%20a%20Connector%20Name%20and%20clicking%20%22Register%22%20I'm%20presented%20with%20%22You%20don't%20have%20access%20to%20perform%20this%20operation%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEvent%20Log%20shows%3A%3C%2FP%3E%3CP%3ERegister%20connector%20start%3A%20LWAPrintTest1%3CBR%20%2F%3ESending%20connector%20registration%20request...%20StatusCode%3A%20403%2C%20ReasonPhrase%3A%20'Forbidden'%2C%20Version%3A%201.1%2C%20Content%3A%20System.Net.Http.StreamContent%2C%20Headers%3A%3CBR%20%2F%3E%7B%3CBR%20%2F%3EX-Content-Type-Options%3A%20nosniff%3CBR%20%2F%3EX-MSEdge-Ref%3A%20Ref%20A%3A%20D4737A22E19846F8BEC8A85BCF9C52FC%20Ref%20B%3A%20DM2EDGE0819%20Ref%20C%3A%202020-11-10T20%3A16%3A57Z%3CBR%20%2F%3ECache-Control%3A%20no-store%2C%20must-revalidate%2C%20no-cache%2C%20max-age%3D0%3CBR%20%2F%3EDate%3A%20Tue%2C%2010%20Nov%202020%2020%3A16%3A57%20GMT%3CBR%20%2F%3ESet-Cookie%3A%20UserRegion%3Dusa%3B%20path%3D%2F%3B%20samesite%3Dlax%3B%20httponly%3CBR%20%2F%3EContent-Length%3A%200%3CBR%20%2F%3E%7D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBoth%20my%20user%20account%20and%20Global%20Admin%20account%20have%20the%20Universal%20Print%20Trial%20license%20assigned%20and%20my%20Global%20Admin%20account%20has%20the%20Print%20Administrator%20Role.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anyone%20assist%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1886089%22%20slang%3D%22en-US%22%3ERe%3A%20Universal%20Print%20Connector%20-%20You%20don't%20have%20access..%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1886089%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F864517%22%20target%3D%22_blank%22%3E%40Chris_Gilles_1337%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EJust%20to%20verify%2C%3C%2FP%3E%0A%3CUL%3E%0A%3CLI%3Eyou%20are%20signed%20in%20to%20the%20connector%20app%20using%20an%20account%20that%20has%20global%20admin%20or%20printer%20admin%20role%20in%20the%20tenant%20where%20you%20are%20trying%20to%20register%20the%20connector.%3C%2FLI%3E%0A%3CLI%3EThere's%20no%20other%20connector%20with%20the%20same%20name.%3C%2FLI%3E%0A%3CLI%3EYou%20didn't%20previously%20register%20a%20connector%20from%20this%20PC%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CP%3EIf%20the%20above%20is%20true%2C%20please%20create%20a%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Fupsupport-azureportal%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3EUP%20support%20ticket%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello,

 

I'm attempting to install the Universal Print Connector on my AAD Joined laptop.

After successfully logging in under my tenant's Global Admin account, entering a Connector Name and clicking "Register" I'm presented with "You don't have access to perform this operation".

 

Event Log shows:

Register connector start: LWAPrintTest1
Sending connector registration request... StatusCode: 403, ReasonPhrase: 'Forbidden', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
{
X-Content-Type-Options: nosniff
X-MSEdge-Ref: Ref A: D4737A22E19846F8BEC8A85BCF9C52FC Ref B: DM2EDGE0819 Ref C: 2020-11-10T20:16:57Z
Cache-Control: no-store, must-revalidate, no-cache, max-age=0
Date: Tue, 10 Nov 2020 20:16:57 GMT
Set-Cookie: UserRegion=usa; path=/; samesite=lax; httponly
Content-Length: 0
}

 

Both my user account and Global Admin account have the Universal Print Trial license assigned and my Global Admin account has the Print Administrator Role.

 

Can anyone assist?

2 Replies

@Chris_Gilles_1337 

Just to verify,

  • you are signed in to the connector app using an account that has global admin or printer admin role in the tenant where you are trying to register the connector.
  • There's no other connector with the same name.
  • You didn't previously register a connector from this PC

If the above is true, please create a UP support ticket.

@Chris_Gilles_1337 

Hi Chris - 

A few things to check:

1. If you applied the UP license via the Azure portal, make sure that the accounts have a "Usage location" configured. The UP license won't apply to the user account correctly if this is not set. You can also try applying the license via the M365 Admin portal. 

2. Go to the Universal Print portal and try to open one of the blades (Printers, Connectors) and see if you get an error. If you do, then the UP license isn't applied to the Administrator account correctly. 

3. If you are able to access the blades on the Portal, check that the following endpoints are not being blocked by your firewall on the system you are trying to install the Connector:

https://login.microsoftonline.com

https://aadcdn.msftauth.net

*.print.microsoft.com

If you are still having an issue, please open a support case via Azure\Universal Print - Preview support topic and we can assist further. 

Philip Demaree

CSS Universal Print Customer Support Lead