SOLVED

Error occurred while registering the connector

%3CLINGO-SUB%20id%3D%22lingo-sub-2074636%22%20slang%3D%22en-US%22%3EError%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2074636%22%20slang%3D%22en-US%22%3E%3CP%3EHello%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe're%20trying%20to%20setup%20UP%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EServer%20meets%20all%20the%20requirements%20listed%20on%20the%20MS%20Docs%20(Win%202016%2B%2C%20.NET%204.7.2%20etc)%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUpon%20logging%20in%20and%20creating%20a%20new%20name%20to%20register%20the%20Connector%20we%20get%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222021-01-19%2015_16_48-Window.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F247469i7BE1267EEF7B249B%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%222021-01-19%2015_16_48-Window.png%22%20alt%3D%222021-01-19%2015_16_48-Window.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20the%20event%20viewer%20we%20are%20shown%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222021-01-19%2015_24_51-Window.png%22%20style%3D%22width%3A%20804px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F247470i7A7F207B95FB7D3F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%222021-01-19%2015_24_51-Window.png%22%20alt%3D%222021-01-19%2015_24_51-Window.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESearched%20and%20searched%2C%20no%20real%20success.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E------------------------------------------------------------------%3C%2FP%3E%3CP%3EThe%20full%20error%20in%20event%20viewer%20reads%3A%26nbsp%3B%3CBR%20%2F%3E-------------------------------------------------------------------------------------------%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CDIV%3EException%20occurred%20while%20initializing%20the%20Proxy%20Service%3A%20System.TypeInitializationException%3A%20The%20type%20initializer%20for%20'ProxyLibrary.Constants'%20threw%20an%20exception.%20---%26gt%3B%20System.DirectoryServices.ActiveDirectory.ActiveDirectoryOperationException%3A%20A%20local%20error%20has%20occurred.%20---%26gt%3B%20System.DirectoryServices.DirectoryServicesCOMException%3A%20A%20local%20error%20has%20occurred.%20at%20System.DirectoryServices.DirectoryEntry.Bind(Boolean%20throwIfFail)%20at%20System.DirectoryServices.DirectoryEntry.Bind()%20at%20System.DirectoryServices.DirectoryEntry.get_AdsObject()%20at%20System.DirectoryServices.PropertyValueCollection.PopulateList()%20at%20System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry%20entry%2C%20String%20propertyName)%20at%20System.DirectoryServices.PropertyCollection.get_Item(String%20propertyName)%20at%20System.DirectoryServices.ActiveDirectory.PropertyManager.GetPropertyValue(DirectoryContext%20context%2C%20DirectoryEntry%20directoryEntry%2C%20String%20propertyName)%20---%20End%20of%20inner%20exception%20stack%20trace%20---%20at%20System.DirectoryServices.ActiveDirectory.PropertyManager.GetPropertyValue(DirectoryContext%20context%2C%20DirectoryEntry%20directoryEntry%2C%20String%20propertyName)%20at%20System.DirectoryServices.ActiveDirectory.Domain.GetDomain(DirectoryContext%20context)%20at%20ProxyLibrary.Constants.IsAdJoined()%20at%20ProxyLibrary.Constants.CheckForImpersonation(JObject%20jsonConfig)%20at%20ProxyLibrary.Constants..cctor()%20---%20End%20of%20inner%20exception%20stack%20trace%20---%20at%20ProxyService.PrintProxyService..ctor()%3C%2FDIV%3E%3CDIV%3E--------------------------------------------------------------------------------------------------------------%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EAny%20help%20greatly%20appreciated.%26nbsp%3B%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2080208%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2080208%22%20slang%3D%22en-US%22%3EWhich%20version%20of%20the%20connector%20are%20you%20trying%20to%20register%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2082730%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2082730%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F442483%22%20target%3D%22_blank%22%3E%40Rani_Abdellatif%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EInstalled%20version%3A%201.34.7683.23618%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2084519%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2084519%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F41521%22%20target%3D%22_blank%22%3E%40Adam%20Weldon-Ming%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ELooking%20into%20it.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3COL%3E%0A%3CLI%3EIs%20your%20connector%20joined%20to%20an%20AD%20domain%20or%20not%3F%3C%2FLI%3E%0A%3CLI%3EAre%20you%20planning%20to%20enable%20the%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Funiversal-print%2Ffundamentals%2Funiversal-print-hybrid-ad-aad-environment-setup%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehybrid%20AD%2FAAD%20config%20mentioned%20here%3C%2FA%3E%3F%3C%2FLI%3E%0A%3C%2FOL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2086452%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2086452%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F442483%22%20target%3D%22_blank%22%3E%40Rani_Abdellatif%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20worries%20-%20thanks%20for%20your%20input.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EThe%20UP%20connecter%20is%20being%20installed%20onto%20a%20Local%20DC%2C%26nbsp%3B%3COL%3E%3CLI%3EThe%20Local%20DC%20is%20where%20the%20printers%20are%20also%20installed%26nbsp%3B%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3CLI%3ELocal%20site%20has%20a%20Express%20Route%20to%20Azure%26nbsp%3B%3COL%3E%3CLI%3EAzure%20also%20has%20a%20DC%20with%20AD%20Connect%20On%20-%20Azure%20DC%20and%20Local%20on-prem%20local%20DC%20replicate%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3CLI%3EEnvironment%20is%20in%20Hybrid%20AD%2FAAD%26nbsp%3B%3C%2FLI%3E%3C%2FOL%3E%3CP%3EThe%20article%20you've%20posted%20throws%20some%20suspicion%20around%20Step%202%20-%20Curious%20if%20I%20should%20follow%20instruction%20in%20Step%202%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2088760%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2088760%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F41521%22%20target%3D%22_blank%22%3E%40Adam%20Weldon-Ming%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThank%20you%20for%20the%20info!%20You've%20actually%20helped%20us%20uncover%20a%20bug.%20We%20are%20fixing%20it%20will%20release%20a%20new%20connector%20version%20ASAP.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERegarding%20your%20question%2C%20if%20I%20understand%20correctly%2C%20you're%20asking%20about%20%22Step%202%20-%20Install%20Application%20Proxy%22.%20I'll%20verify%20and%20get%20back%20to%20you.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2094552%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20occurred%20while%20registering%20the%20connector%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2094552%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F442483%22%20target%3D%22_blank%22%3E%40Rani_Abdellatif%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELook%20forward%20to%20the%20new%20release.%20Once%20released%20I%20will%20mark%20solved.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hello

 

We're trying to setup UP, 

 

Server meets all the requirements listed on the MS Docs (Win 2016+, .NET 4.7.2 etc) 

 

Upon logging in and creating a new name to register the Connector we get: 

 

2021-01-19 15_16_48-Window.png

 

In the event viewer we are shown: 

 

2021-01-19 15_24_51-Window.png

 

Searched and searched, no real success.  

------------------------------------------------------------------

The full error in event viewer reads: 
-------------------------------------------------------------------------------------------

Exception occurred while initializing the Proxy Service: System.TypeInitializationException: The type initializer for 'ProxyLibrary.Constants' threw an exception. ---> System.DirectoryServices.ActiveDirectory.ActiveDirectoryOperationException: A local error has occurred. ---> System.DirectoryServices.DirectoryServicesCOMException: A local error has occurred. at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) at System.DirectoryServices.DirectoryEntry.Bind() at System.DirectoryServices.DirectoryEntry.get_AdsObject() at System.DirectoryServices.PropertyValueCollection.PopulateList() at System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName) at System.DirectoryServices.PropertyCollection.get_Item(String propertyName) at System.DirectoryServices.ActiveDirectory.PropertyManager.GetPropertyValue(DirectoryContext context, DirectoryEntry directoryEntry, String propertyName) --- End of inner exception stack trace --- at System.DirectoryServices.ActiveDirectory.PropertyManager.GetPropertyValue(DirectoryContext context, DirectoryEntry directoryEntry, String propertyName) at System.DirectoryServices.ActiveDirectory.Domain.GetDomain(DirectoryContext context) at ProxyLibrary.Constants.IsAdJoined() at ProxyLibrary.Constants.CheckForImpersonation(JObject jsonConfig) at ProxyLibrary.Constants..cctor() --- End of inner exception stack trace --- at ProxyService.PrintProxyService..ctor()
--------------------------------------------------------------------------------------------------------------
 
Any help greatly appreciated.  


9 Replies
Which version of the connector are you trying to register?

@Rani_Abdellatif 

Installed version: 1.34.7683.23618  

@Adam Weldon-Ming 

Looking into it.

 

  1. Is your connector joined to an AD domain or not?
  2. Are you planning to enable the hybrid AD/AAD config mentioned here?

@Rani_Abdellatif 

No worries - thanks for your input. 

 

  1. The UP connecter is being installed onto a Local DC, 
    1. The Local DC is where the printers are also installed 
  2. Local site has a Express Route to Azure 
    1. Azure also has a DC with AD Connect On - Azure DC and Local on-prem local DC replicate
  3. Environment is in Hybrid AD/AAD 

The article you've posted throws some suspicion around Step 2 - Curious if I should follow instruction in Step 2

@Adam Weldon-Ming 

 

Thank you for the info! You've actually helped us uncover a bug. We are fixing it and will release a new connector version ASAP. 

 

Regarding your question, if I understand correctly, you're asking about "Step 2 - Install Application Proxy". I'll verify and get back to you.

Thanks @Rani_Abdellatif 

 

Look forward to the new release. Once released I will mark solved. 

 

 

@Adam Weldon-Ming 

 

Thanks. We're working on releasing the new connector version ASAP.

 

Regarding your about "Step 2 - Install Application Proxy":

Please use the dsregcmd to check whether the PC is Hybrid AD Joined. If it is, you can skip step 2.

Also, installing App Proxy when it's not needed doesn't negatively affect the setup.

Best Response confirmed by Adam Weldon-Ming (Contributor)
Solution

@Adam Weldon-Ming we have a canary/pre-release version of Connector with a few fixes, including this crash. Can you try upgrading to it via https://aka.ms/ConnectorMSI-Canary and trying to run the Connector again? Please let us know if you see any issues or if it ends up resolving the issue you were seeing earlier.

 

Thanks

@keeron @Rani_Abdellatif 

 

Hi guys,

 

This has worked, new version did not crash with the error form before - we will continue our setup this side - Many thanks for your input and prompt resolution. 

 

Adam