error AADSTS50020

%3CLINGO-SUB%20id%3D%22lingo-sub-1513971%22%20slang%3D%22zh-CN%22%3Eerror%20AADSTS50020%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1513971%22%20slang%3D%22zh-CN%22%3E%3CP%3EI%20can't%20use%20Universal%20Print%20connector.%20%3CSPAN%3E%20I%20get%20an%20error%20time%20time%20i%20use%20it%2C%20the%20code%20error%20is%20AADSTS50020%3A%20%22User%20account'%20s'%20from%20the%20%22from%20the%20object'%20live.com'%20do%20snot%20tenant%20tenant%20'Microsoft%20Services'%20and%20cannot%20arcys%20the%20application%20(connector)%20in.%20The%20account%20account%20to%20be%20as%20san%20external%20user%20in%20the%20tenant%20first.%20Sign%20out%20and%20sign%20in%20again%20again%20with%20a%20tha%20Azure%20Active%20Directory%20user%20account.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22john_wang_0-1594373244959.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F204560iBD0B1F222D9EA3DC%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22john_wang_0-1594373244959.png%22%20alt%3D%22john_wang_0-1594373244959.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22john_wang_1-1594373277725.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F204561iE8953707E8F7E4EB%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22john_wang_1-1594373277725.png%22%20alt%3D%22john_wang_1-1594373277725.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1517600%22%20slang%3D%22en-US%22%3ERe%3A%20error%20AADSTS50020%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1517600%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F724654%22%20target%3D%22_blank%22%3E%40john_wang%3C%2FA%3E%26nbsp%3Bwhat%20user%20are%20you%20signing%20in%20with%3F%20Seems%20like%20you%20are%20using%20your%20live.com%20ID%20which%20is%20a%20personal%20Microsoft%20email.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ETo%20sign-in%20to%20the%20connector%2C%20you%20need%20to%20have%20a%20Azure%20AD%20tenant%20and%20signin%20as%20the%20global%2Fprint%20admin%20of%20that%20tenant.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%2C%3CBR%20%2F%3ESaurabh%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1522561%22%20slang%3D%22zh-CN%22%3ERe%3A%20error%20AADSTS50020%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1522561%22%20slang%3D%22zh-CN%22%3E%3CBR%20%2F%3EThanks%20for%20the%20reply%2C%20I%20used%20a%20Microsoft%20account%20to%20log%20in%2C%20this%20account%20is%20also%20azure%20global%20global%20account%2C%20and%20applied%20for%20the%20print%20identity%20identity%20administrator%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1522689%22%20slang%3D%22en-US%22%3ERe%3A%20error%20AADSTS50020%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1522689%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F724654%22%20target%3D%22_blank%22%3E%40john_wang%3C%2FA%3E%26nbsp%3B-%20if%20you%20are%20logging%20in%20as%20Azure%20AD%20tenant%20admin%20(not%20MSA)%20and%20still%20facing%20issue%2C%20please%20reach%20out%20to%20Microsoft%20Support%20via%20Azure%20Support%20portal.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I can't use Universal Print connector.I get an error every time I use it, the error code is AADSTS50020:"User account '*********' from identity 'live.com' does not exist in tenant 'Microsoft Services' and cannot accsee the application(Universal Print Connector) in that tenant. The account needs to be added as an external user in the tenant first.Sign out and sign in again with a different Azure Active Directory user account.

 

 

 

john_wang_0-1594373244959.png

john_wang_1-1594373277725.png

 

 

3 Replies

@john_wang what user are you signing in with? Seems like you are using your live.com ID which is a personal Microsoft email.

 

To sign-in to the connector, you need to have a Azure AD tenant and signin as the global/print admin of that tenant.

 

Thanks,
Saurabh

 


Thanks for the reply, I used a Microsoft account to log in, this account is also an Azure global administrator account, and applied for the print administrator identity

@john_wang - if you are logging in as Azure AD tenant admin (not MSA) and still facing issue, please reach out to Microsoft Support via Azure Support portal.