Driver unavailable

%3CLINGO-SUB%20id%3D%22lingo-sub-2888780%22%20slang%3D%22en-US%22%3EDriver%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2888780%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20seem%20to%20run%20across%20a%20bug.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20universal%20print%20setup%20correctly%20with%20a%20print%20connector.%20I%20can%20add%20a%20printer%20and%20everything%20will%20work.%20however%20if%20I%20go%20to%20settings%20and%20remove%20the%20printer%20then%20attempt%20to%20add%20it%20back%20later%20it%20will%20get%20stuck%20at%20connecting%20and%20never%20add.%26nbsp%3B%20if%20I%20check%20control%20panel%20it%20will%20report%20drive%20unavailable%26nbsp%3B%20and%20the%20only%20way%20i%20can%20ever%20get%20that%20printer%20to%20ever%20add%20again%20is%20to%20log%20off%20the%20pc%20log%20in%20as%20and%20admin%20and%20delete%20the%20user%20profile%20and%20then%20sign%20back%20in%20and%20readd%20the%20printer.%20Anyone%20know%20why%20or%20how%20to%20fix%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDevice%20manager%20shows%20a%20Device%20unknown%20under%20printers%20and%20says%20the%20driver%20is%20not%20signed%20or%20not%20signed%20in%20the%20appropriate%20manner%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2901682%22%20slang%3D%22en-US%22%3ERe%3A%20Driver%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2901682%22%20slang%3D%22en-US%22%3EAre%20you%20re-adding%20printer%20on%20a%20connector%20(using%20the%20printer%20OEM's%20driver)%20or%20are%20you%20adding%20a%20Universal%20Print%20printer%20on%20user's%20device%3F%3CBR%20%2F%3E%3CBR%20%2F%3ERecommend%20reaching%20out%20to%20Microsoft%20Support%20-%20%3CA%20href%3D%22https%3A%2F%2Fportal.azure.com%2F%23blade%2FMicrosoft_Azure_Support%2FHelpAndSupportBlade%2Foverview%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fportal.azure.com%2F%23blade%2FMicrosoft_Azure_Support%2FHelpAndSupportBlade%2Foverview%3C%2FA%3E%3C%2FLINGO-BODY%3E
Senior Member

I have seem to run across a bug.  

 

I have universal print setup correctly with a print connector. I can add a printer and everything will work. however if I go to settings and remove the printer then attempt to add it back later it will get stuck at connecting and never add.  if I check control panel it will report drive unavailable  and the only way i can ever get that printer to ever add again is to log off the pc log in as and admin and delete the user profile and then sign back in and readd the printer. Anyone know why or how to fix this?

 

Device manager shows a Device unknown under printers and says the driver is not signed or not signed in the appropriate manner

 

This occurs on an AADJ device on both windows 10 21H1 and windows 11 22000.258

1 Reply
Are you re-adding printer on a connector (using the printer OEM's driver) or are you adding a Universal Print printer on user's device?

Recommend reaching out to Microsoft Support - https://portal.azure.com/#blade/Microsoft_Azure_Support/HelpAndSupportBlade/overview