Cannot discover printers

%3CLINGO-SUB%20id%3D%22lingo-sub-2131884%22%20slang%3D%22en-US%22%3ECannot%20discover%20printers%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2131884%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20had%20Universal%20Print%20working%20before%2C%20but%20I%20have%20reinstalled%20my%20computer%20last%20week%20and%20now%2C%20I%20cannot%20discover%20any%20cloud%20printer%20anymore.%20To%20be%20sure%20that%20everything%20is%20configured%20correctly%2C%20I%20have%20reinstalled%20everything%2C%20according%20to%20the%20Microsoft%20documentation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20connector%20service%20on%20my%20printserver%20is%20working%20fine%2C%20registered%20printers%20appear%20in%20the%20Azure%20portal.%20From%20there%2C%20I%20share%20a%20printer%20for%20everyone%20in%20the%20organization.%20I%20have%20also%20redeployed%20the%20Universal%20Print%20Printer%20Provisioning%20service%20on%20my%20computer%20and%20I%20have%20configured%20Intune%20to%20run%20the%20'installpolicy.cmd'%20script.%20The%20'printers.csv'%20file%20appears%20in%20%25appdata%25%5CUniversalPrintPrinterProvisioning%5CConfiguration%20folder%20and%20contains%20the%20right%20share%20ID%20and%20share%20name%20of%20the%20printer.%20My%20computer%20is%20AAD%20joined%20and%20my%20user%20account%20is%20licensed%20for%20Universal%20Print.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStill%2C%20I%20don't%20see%20any%20cloud%20printer%20after%20logging%20in%2C%20or%20searching%20for%20printers.%20I%20also%20do%20not%20see%20the%20link%20to%20search%20for%20cloud%20printers%20after%20a%20regular%20discovery.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAm%20I%20missing%20something%3F%20Is%20there%20some%20extensive%20logging%20I%20can%20take%20a%20look%20at%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2154924%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20discover%20printers%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2154924%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F288051%22%20target%3D%22_blank%22%3E%40leoschroer%3C%2FA%3E%26nbsp%3Bare%20you%20logged%20in%20with%20your%20Azure%20AD%20credentials%3F%20Do%20you%20by%20any%20chance%20have%20more%20than%20one%20Azure%20AD%20account%20in%20workplace%20join%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20you%20continue%20to%20face%20issue%2C%20please%20file%20a%20support%20case%20from%20Azure%20Support%20Center.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

I have had Universal Print working before, but I have reinstalled my computer last week and now, I cannot discover any cloud printer anymore. To be sure that everything is configured correctly, I have reinstalled everything, according to the Microsoft documentation.

 

The connector service on my printserver is working fine, registered printers appear in the Azure portal. From there, I share a printer for everyone in the organization. I have also redeployed the Universal Print Printer Provisioning service on my computer and I have configured Intune to run the 'installpolicy.cmd' script. The 'printers.csv' file appears in %appdata%\UniversalPrintPrinterProvisioning\Configuration folder and contains the right share ID and share name of the printer. My computer is AAD joined and my user account is licensed for Universal Print.

 

Still, I don't see any cloud printer after logging in, or searching for printers. I also do not see the link to search for cloud printers after a regular discovery.

 

Am I missing something? Is there some extensive logging I can take a look at?

2 Replies

@leoschroer are you logged in with your Azure AD credentials? Do you by any chance have more than one Azure AD account in workplace join?

 

If you continue to face issue, please file a support case from Azure Support Center.

 

Hi @Saurabh_Bansal 

 

Thanks for your reply. My computer is Azure AD Joined and there were no additional Work, or personal accounts configured.

 

Over the weekend, I have redeployed my computer with Autopilot and now I can discover the cloud printers again. My issue has been resolved.