SOLVED

Love the Community, Hate the Website

Contributor

There's so much good content, discussion, and great people in Microsoft Tech Community. Sadly, a few problems with the website make me dread using it:

 

  1. Response time is horrible (and has been for as long as I can remember): Clicking on any link always results in a 6 to 12 second delay. And this is on a modern laptop with 16GB of RAM, i7 CPU, SSD and avg. network speed of around 120 Mbps. It's as if someone built the website in a low-resource, low-priority Azure VM and forgot to re-provision it for production.
  2. The number of characters displayed per comment before triggering the "Read more >"  control is too small: This forces us to click Read more in what seems like a majority of cases. Often, just a few more words are revealed. This means a slightly larger allocation could drastically reduce the number of partially hidden comments.
  3. Clicking Read more > navigates to a separate, dedicated page for that one comment and it's parent instead of simply expanding in-place. Like clicking any other link, there's a 6 to 12 second delay which turns a mere annoyance into a nightmare. 
  4. After clicking Read more >, there doesn't seem to be any reliable way to navigate back to where you left off in the larger thread. This means we have to repeatedly scroll back to our previous position in the thread. In a very long discussion thread, this is akin to Chinese water torture.

The biggest mystery to me is why everyone isn't constantly up-in-arms about these issues. Is this somehow only happening to me? Am I expecting too much?

6 Replies
This happens to me too. Just wanted to let you know you're not alone. I feel the same way...
LOL, What could you expect from Tech Community of the biggest Software company in the world?
It's only been 2 years since the original post.
I'm sure they never noticed any problem and they just need a bit more time to fix it....



best response confirmed by Mike Glenn (Contributor)
Solution

@Cibavision & @conyeje2EY 

 

Thank you for taking the time to post in agreement of the original post. During 2020 we did a whole lot of work to improve our community response time (i.e. remove old code, getting better and smarter at caching data that didn't need to be 'live', moving the community in to the Azure Cloud, reducing our dependency on external JavaScript etc), and this did significantly improve page load time.

 

What we are seeing is, certainly for the last 48 hours, the site has been periodically much slower than normal, but only for some users. We have our engineering team investigating the cause of this and we hope to have it resolved shortly.

 

Job done? No not at all, we are about as fast as the current platform will allow and so since the pandemic hit we have been working with our vendor to update the whole technology stack to achieve a few objectives:

 

  • Improve overall accessibility of the site and help users create content to make their content easier to consume for all.
  • Move from the current code stack the community is on to one that is designed to work in the cloud.
  • A complete reskin of the site to update our IA, UI and UX to faciliate the much bigger and more successful community we have become. 

These are to name but a few of the things we are working on, and as we get closer to delivering on these I fully ancticipate asking community members for their input as well. 

 

The average time taken for a page to load prior to the issue we discovered in the last 48 hours was 3.5 seconds. (still not stellar but an improvement on the 6-8 seconds we are seeing at the moment).

 

I will let you know when we have an update. 

@Allen thanks for responding to this issue. The website does feel a lot more responsive than it did two years ago when I originally made this post. I know these things take time. But it is a bit strange that someone @responded directly to two commenters agreeing with my post, but never responded to me.

 ¯\_(ツ)_/¯

@Mike Glenn 

I am sorry I never replied to your original post, we actually had another thread going on at the same time about the same issue which I did a @everyone style reply to. The intention at the time was to merge the posts together but clearly that never happened.

 

I am pleased you find the site faster than when you originally posted but I hope you will agree it could still be faster. 

Really at this point all I can do is assure you that not replying to your original post was an oversight not a deliberate act.

 

I hope you will accept my apology in this matter.


Allen

Wow, waiting about 2 years for a response down to 10 minutes is a huge improvement all by itself! Clearly the current team is on the ball and making improvements all around. No worries on the oversight. I'm just happy to see things moving in a positive direction. Even emoji are working now! 👍🏼