Cannot change community profile picture


I'm signing in with my work email here into the Office 365 Network.

I would like to set up a community profile picture. When I open my community profile page there's a hand cursor showing on top of the default grey buddy avatar. But clicking on it shows loading for does nothing. Tried with Edge and Chrome.


Funnily enough the avatar shows a hand cursor even when not signed in...

12 Replies

I had the same - closed my browser, reopened it, no change. Tried 10 minutes later, and it worked. Suspect it could be a transient issue that requires a bit of patience and a good helping of luck.

it depends on size of your photo had to cut and past some things

I'm having the same issue.


I get as far as a page that says to go to a My Images link on my profile, but that link does not exist.


Did you get any resolution?

Same issue here. I can't upload a picture. I was able to link to my Facebook picture temporarily, but I prefer to upload a different pic.

I also can't upload a picture.

Hi @Nathan Wells, here's more info in the Getting Started Guide on how to add a profile photo. Please reach out if you have additional questions.








Thanks @Lana O'Brien It's actually not an issue of me not understanding how - it's that the website isn't working as it should.

All I get is a blank white window:



Doesn't matter how long I keep it open - just stays white.

7 months later and this still happens. Can't figure it out. In my scenario, I have two accounts - a personal and a work (AD), both with the same email to login. When I connect to techcommunity with the work account, I can change profile picture but when I use personal one I get the blank window (any browser). I'm wondering if this is part of the issue?



I miss the beginning of this thread.  Would you please repeat for me the basic process to add my photo to my profile on this Tech Community?  Thanks!

-Ron White

I get the identical results....just a blank page attempting to upload an avatar. Amazing and downright embarrassing that Microsoft cannot allow some people for months to not upload a photo, yet in Delve I can update my picture in 10 seconds...Yet another half-baked product. 

I just got avatar uploaded..not in Chrome or Edge, but I downloaded latest Firefox v62.0.3 (Quantum)

I had the same blank screen when trying to upload via Chrome. However it did work in Internet Explorer. Other users have had luck with Firefox as well.