Can't change email for notifications here

Silver Contributor

I have tried to change the email for notifications in the community in my profile (i want to use my own domain email instead of one linked to my MS account). So i have filled the new email and never received a confirmation email. Today i have found this in my email logs:


2018-07-13 email(no subject)REJECTED
Sender's domain is missing DNS records
11 Replies
best response confirmed by wroot (Silver Contributor)

Thanks for posting, I can only assume your mail server is trying to look up our A record for Which doesn't exists... for good reason.. there is no server on the end of that domain that you can navigate to from a web browser.

I am afraid all I can ask you to do is get the network admin to whitelist the emails at this time.

Oh, somehow i didn't thought about it myself, although i whitelist senders quite often. Did it now and received the notification. Changed my email. Thanks.

Today my email switched back to old one in the settings on its own.. My god, this site is broken in so many ways. It works so slow, on mobile it's  almost impossible to use. MS should do better job if they want to grow a community here..

I guess it is doing this when i login again as my login is tied to the old email address, which i can't change (my MS account is tied to an old hotmail address, which i would delete on a whim if i could just switch everything tied to it to my own address).


Correct the email address in use is populated via the Microsoft Account you use to login. You can of course change the primary Alias on your Microsoft account to a different email address, see

Then when you login the next time it will be updated in the community. The system is designed to make it easy for users to sign up, and while I appreciate some users do hit some issues with this, its not a common feedback point from the community.

I am however very interested on your feedback about the speed of the website and mobile viewing.

There are a limited number of times where I would expect a user to see a page load time of over 4 seconds and so having said that I would love to hear more about where you encountered this slow page load, what device you are using to access the site and what browser. Could you also confirm what type of network connection you are on and the country you are connecting to the site from to allow me to investigate further.

As for mobile pages we have done some work to optimize pages but we know we still have more to do and we have plans to do some refactoring of some pages later in this fiscal year.

I am sorry your having so many issues and look forward to additional feedback.

Will have to explore the option of changing MS ID alias. Thanks. For now i have enabled forwarding.


Now feedback. And i don't intend to sound rude or snarky. First i want to express the emotion when using this website - clunky. Whether i use it on my desktop with Firefox (Quantum) or with mobile Chrome. There are a lot of pauses, loading. I never thought i would compare to Discourse, as i didn't like some of its aspects at first, but its fluidness compensates every little quirk. You press to reply and the input window is there in a second. You press to post and it posts in a blink of an eye, no matter mobile or desktop. You can open huge threads in a second and it loads new messages dynamically while scrolling, no pagination needed.


Details. First i must mention these 3 big blobs at the top of the site. Ignite, etc. I know it looks pretty, but it just takes so much space, on mobile they are aligned vertically, so you have to scroll below them to get 5 topics and then press to load more and to press again and again. Whole frame feels so cramped and limited. I'm eager to check many different topics and participate, but i quickly get annoyed by such flow.


Topic loading on mobile with 4G (LTE) takes 5-7 seconds. My connection is not a problem i think as it is fast enough for everything i use. Latest mobile Chrome (although Android is stuck on 5 due to manufacturer), with 2 GB of memory and 8 cores, Huawei Mediapad X2. Country: Lithuania (Eastern Europe).


Posting a reply is worse. I use default Rich Text. Even on desktop you have to wait a few seconds for the editing toolbar to load. If i try to press quickly into input field or type it sometimes jumps around and misinterpret my typing. I guess it wants to load everything first. On mobile it takes longer. Probably 5-7 seconds again. Then i have to struggle to actually get to type. I press into input window. Cursor blinks and disappears. I have learned not to press to soon and wait for a few seconds, but it still usually takes a few tries before i get a keyboard. Everything slides to the top and input cursor is hidden behind the fixed top bar of a site, so to see what i type i have to press and pull in the typing area to bring it back to view, which often resets the typing focus and i have to click in there again and try to pull it to view again. When i'm done typing and press Post it shows a visual feedback on the Post button, but then for 6 or even 8 seconds nothing happens and it looks like the page has frozen (i have just tried this on Wifi). I have learned just to wait and not try to press again or anything. No loading bar is showing at the top. It seems that page is reloaded behind the input window and then after this pause is presented immediately showing first message, then view slides to the bottom, but usually not to my posted message, but one or few above it. There should be some indication when going to the thread after posting (when it takes so long). At least same browser's loading bar like when opening a thread.


On mobile i can't switch to further pages in long threads. Nothing happens when i press on 2. I have waited long enough. No reaction at all.


Today i was typing a reply for maybe 10 minutes and accidentally pressed back. My connection was up all the time and it didn't provide me autosaved message. Not sure if i saw such banner at all. Maybe autosave is not working for mobile. I do see it on desktop.


I have noticed that it sends email notification for every edit of a same message. Not sure if by design. But maybe an overkill. I am a clumsy typer, but on this site i keep myself from fixing typos, so i won't flood someone's mailbox with useless notifications.

Posting message above on desktop took around 8 seconds between pressing Post and page completely loaded.

Thank you for the lengthy feedback. I wont patronize you by trying to answer your points without investigating further, something which I will do.

I do not recognize this experience from either of the devices I am testing with (iPhone 8 or Nokia 7) but both of those devices are using the latest OS.

I will try to find an older android device and try from them and see if I can create the same experience.

Another issue i have found. Uploading images on mobile. Regular upload button gets overlapped with "tap to upload options".

Just got a new phone with Android 9. Experience is mostly the same as with my old tablet. Still sluggish and often there is no visual feedback after pressing Post button. Just have to wait for 5-10 seconds for the page to start reloading with your new post. Also, maybe this is because of a phone factor, but it doesn't show editor toolbar for me. So, can't change formats or insert images inline.
For some reason for a few days i am now not able to press Reply button in a post when Reply is shown on the left side and not in the right (don't know why it shows on the left sometimes). Then only quick post works and Reply button just jumps and nothing happens. Latest Chrome on Android 9.
1 best response

Accepted Solutions
best response confirmed by wroot (Silver Contributor)

Thanks for posting, I can only assume your mail server is trying to look up our A record for Which doesn't exists... for good reason.. there is no server on the end of that domain that you can navigate to from a web browser.

I am afraid all I can ask you to do is get the network admin to whitelist the emails at this time.

View solution in original post