a nasty bug that prevents adding a picture when editing a comment after few hours

Honored Contributor


In the past few weeks, I've been experiencing this bug, here are things I know about it.


  1. after posting a comment, if I try to edit in in the first few minutes, I can add pictures to it, but if i wait few hours or longer and then try to edit it, I can't add pictures to it.
  2. when I click on the camera icon on the post editor toolbar, nothing happens.
  3. I tried on other browsers too, still the same behavior.
  4. when I upload the picture to imgur instead, and then paste the direct link to the post, the picture successfully shows up in the post, but then the "post" button won't work, so I can't save the edits.


the only solution is to delete the whole comment and then post it again, with the picture.



Developer tools shows CORB errors (Cross-origin Read Blocking), when I click on the camera icon to add pictures (as you can see I've clicked on it 18 times)





3 Replies



It sounds annoying, whatever is going on in the dev console is not likely to be related though, the errors your showing are all to do with the Microsoft Web Analytics - although they are interesting too so I will look at them separately.


I will do some testing with your repo steps below and let you know what I find.

Thank you,
btw Tracking prevention in Edge and ublock origin extension are all turned off on Microsoft domains on my browsers.

I successfully reproduced this on Windows Sandbox using EdgeHTML (Edge legacy) browser.

the post I tried to add picture to is from 4 days ago.