Trying to customize Communities App

Brass Contributor


I have tried to customize our Communities App to look like our company's own app. I have global admin rights and adjustments has been done here: Teams admin >> Teams Apps >> Manage Apps. I had difficulties to publish the texts and I somehow managed to publish them when doing it very many times. I still haven't managed to publish the logo nor the outline logo. If I try this, there will be a notification saying:  "Warning We can't display the image of this private app. To see the image, you must get a license." The logo sizes are correct and also the file format (.png).  As far as I know our licenses should be ok. Or is this notification referring to the advanced communication license? 

11 Replies
Hi @Sari Kangas,
Can you share more details on the app you need to update ? Is it a custom app you are uploading or communities app by Microsoft which is already present in store ?

Hi @Prithvi-MSFT
Thank you for the help!
It is the Communities App by Microsoft. I have managed to change the 'Communities' name to our own and also the related texts have been changed.
As you can see from the pic below the name has changed but the logo is still Yammer logo and not our own. 


I've had also problems when trying to change the Color icon. So the problem is with the icon logos. We have our own logos with the correct sizes and in PNG format but still no success changing them.

When I try to change the Color icon I will only receive this error message:


The same goes with the Outline Icon. Same error text appears when trying to change it.  

Hi @Sari Kangas,
We have raised a bug for this. The concerned team is looking into it.

Thank you so much! We still have the sam problem where we cannot change the custom logo. Looking forward to your solution.
@Prithvi-MSFT What's the status? Same problem here, trying to upload a custom log for the Viva Connections app, get the same exception as @Sari Kangas. Thank you for your feedback. Regards, Ben
The status is still the same. No change there :( We have managed to change the name Yammer to something else but the image problems still remains.

@Sari Kangas today I have experienced exactly the same issue. Have you received any feedback from Microsoft yet? Thank you in advance,

Ok, I actually found the resolution online; admin account that you use to publish the app needs a license; it's not exactly known which license, I'm working now with E5 temporarily and that works fine; see this thread:
No, I haven't had any further assistance about this matter. But as it so happens the new logo images are now visible and in use. I'm afraid I do not know exactly why this is so :(
Even though this now works in our environment I appreciate Aneta all your help and efforts. I will read through the link you provided. Thanks again!
@Sari Kangas-Bug is fixed. Could you please check it once from your end and let us know?