Teams Tab App Not Working On External Web Server

Contributor

Hi,

 

I'm trying to deploy my Teams tab app on an external Tomcat web server but Teams is not rendering the tab. i.e. the tab is blank.

 

However, when I use ngrok and deploy the same Teams tab app in Tomcat on my localhost server, it works fine. I have used the Wireshark packet capture tool to verify the external Tomcat server is receiving and responding to the messages from the Teams app.

Do I need to configure anything in the manifest.json file and/or Azure AD to allow my Teams tab app to  handle TLS or to recognize the external server? Is there a difference between ngrok and Tomcat in how TLS handled?

 

Is there a log file generated from rendering my Teams tab app? If so, where is it located?

 

Thanks!

George

 

 

4 Replies

@George71 - Did you add valid domain to the manifest?

@Nikitha-MSFT 

I did add a valid domain to the manifest.json file. Here is my manifest file:

{
    "manifestVersion": "1.7",
    "version": "1.0.0",
    "id": "243244b2-5499-4442-864b-9e6be093ebbf",
    "packageName": "com.gctest",
    "developer": {
        "name": "GcTest",
        "websiteUrl": "https://www.microsoft.com",
        "privacyUrl": "https://www.microsoft.com/privacy",
        "termsOfUseUrl": "https://www.microsoft.com/termsofuse"
    },
    "icons": {
        "outline": "contoso20x20.png",
        "color": "contoso96x96.png"
    },
    "name": {
        "short": "GENCom App",
        "full": "GENCom App for Microsoft Teams"
    },
    "description": {
        "short": "App for Microsoft Teams",
        "full": "This app provides an innterface to make GENCom voice calls from within Microsoft Teams."
    },
    "accentColor": "#60A18E",
    "staticTabs": [
        {
            "entityId": "com.gctest.findcontacts",
            "name": "Contact List",
            "contentUrl": "https://172.29.120.99/gctest/findcontacts.html",
            "scopes": [
                "team"
            ]
        }
    ],
    "permissions": [
        "identity",
        "messageTeamMembers"
    ],
    "validDomains": [
        "172.29.120.99"
    ]
}

@George71 - IP address will not support for the tab. Valid you please try adding the web domain instead of IP address? Try if that helps.