Teams Custom App no Install Button

Copper Contributor



I created a Teams app in Power App and exported it. After that I imported it to There i made some changes. Then i exported it again. And finally i imported it to Teams Admin Center. But in Teams there is no install Button. Can you help me?



We have to do it this way, because we want to Pin the App fix in Teams on the front panel.


We already use custom Teams Apps.




Thanks for your help


7 Replies

@Pludan - Could you please share your manifest zip?


{"$schema":"","version":"1.0.4","manifestVersion":"1.12","id":"","packageName":"","name":{"short":"ibW Support","full":"ibW Support App"},"developer":{"name":"ibW Daniel Plump","websiteUrl":"","privacyUrl":"","termsOfUseUrl":""},"description":{"short":"Mail und Anruf","full":"Direkt linkt zur Support-Mail Adresse und Support Nummer"},"icons":{"outline":"outline.png","color":"color.png"},"accentColor":"#7B8086","validDomains":[],"webApplicationInfo":{"id":""},"devicePermissions":["OpenExternal"],"defaultInstallScope": "personal","defaultGroupCapability": {"meetings": "tab","team": "bot","groupchat": "bot"},"configurableProperties":["name","shortDescription","longDescription","smallImageUrl","largeImageUrl","accentColor","privacyUrl","developerUrl","termsOfUseUrl"],"authorization":{"permissions":{"orgWide":[],"resourceSpecific":[{"name":"InAppPurchase.Allow.User","type":"Delegated"},{"name":"InAppPurchase.Allow.Group","type":"Delegated"},{"name":"ChannelMeetingParticipant.Read.Group","type":"Delegated"},{"name":"ChannelMeeting.ReadBasic.Group","type":"Delegated"}]}}}


@Pludan75- We are looking into this I will get back to you soon.

@Pludan75 -It looks like, User does not have permission to add the APP in Teams.

Could you please check the app permission policies in Teams?

Ref Doc :- Manage your apps in the Microsoft Teams admin center - Microsoft Teams | Microsoft Docs



Thank you for your reply. The permissions all look ok




@Pludan75 -Have you added teams in bot channel registration?

I also facing same issue but after adding teams in bot channel registration it was visible.

Attached manifest json .Could you please check it once?





If the response is helpful, please click "**Mark as Best Response**" and like it. You can share your feedback via Microsoft Teams Developer Feedback link. Click here to escalate.

Thank you for your help.
It worked with your manifest. I added a bot channel to the original. Now it works as desired and the add button is available :)