Team UI changes the way our Bot works

Copper Contributor

Morning everyone.


A few months ago something in Teams changed and our Bot that uses dropdowns using borframework, now has these 'X' on the dropdown. What is happening is our users are clicking on the X thinking the dropdown would open, but it clears whatever selection they had. Meaning they need to pick something again, and in most cases, they submit with nothing selected and this causes issues.


Does anyone know how we can fix this that the dropdown shows the down arrow chevron like in the image?  



Team using botframework error.pngdown arrow.png

11 Replies

@PieterVanHeerden - Could you please share the Card JSON which you are using?

@Prasad_Das-MSFT thanks for the response,


We are actually using C# and building the card up using the classes and not the json card

Ill give you a snippet below. The dropdowns behave right in the bot emulator only in teams when we see the "x"




We tried with the ActionSet and AdaptiveChoiceSetInput class thats comes from 

Assembly AdaptiveCards, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35



@PieterVanHeerden - Could you please share the code snippet or sample you are referring to ?

Hi Prasad, let me build one as to give you just a snippet will be hard. I will upload a very small demo sample of the issue, but it needs to be deployed to teas before you will see or experience the issue ok

@Prasad_Das-MSFT here you go

@PieterVanHeerden - Tried setting up the sample provided, and getting the card having dropdown as below:


After choosing any option from dropdown, getting the card as below having 'x' icon using which you can deselect the selected item


which seems to be default behaviour

hi. Yes this was not the case a few versions back on teams, and I dont know how to switch this off?
Another thing that also changed on teams is the commands you add in the manifest for things like...what can i etc. In the past, once you started typing, you would see the help menu when needed. now as soon as the bot opens in teams, this help command menu also just opens by teams has definitely changed some things on their end which by the looks of it, we dont have any control over?

@PieterVanHeerden - Yes we observed the same as well. But these features seems like by design and can't be changed.

this is really sad news. and it affects user experience. Maybe you can then let me know the following. when we use that sample, and you click the X button and it then says "select an option", how can you make it required before you submit to the server or to then default it to the selected option "None", because if a user selected option A, and then hit the X, it blanks out their choice. Our users think when clicking on the X, it will show them the dropdown. so this messes things up for them

@PieterVanHeerden - Please follow below doc to make the choice field input required before submitting the response.
Input Validation - Adaptive Cards | Microsoft Docs

@PieterVanHeerden - If your issue has resolved with above suggestion, could you please accept the answer for more visibility?