Take ownership error when trying to get ownership of Teams store app

Copper Contributor

Hello,

We would like to update our Teams store application, but are unable to do so. Originally it was published by a developer who has left our company and we removed his Azure/Microsoft account. Therefore we tried to take ownership of the app by performing following steps:

1) We logged in (as global admin) on https://dev.teams.microsoft.com

2) There we could not see the 'Xelion' app with ID '08865b6f-dad8-4678-9697-9ba38e0a653b'.

3) We tried to get back the ownership by clicking (as global admin) on the 'Take ownership' button.

4) We entered the app id '08865b6f-dad8-4678-9697-9ba38e0a653b' and hit the 'Recover' button.

5) We've got following error message

 

Take ownership error

You do not have the rights to take over the app "08865b6f-dad8-4678-9697-9ba38e0a653b" .
(Tracking info: d5f1a7ab-c42f-41dc-928f-daecbb2207ad_229 Tue, 06 Feb 2024 15:24:23 GMT | Status code: 403)


Could you please help with this issue?


9 Replies
Thank you for reporting this, we will check this and get back to you.

@finrodFelagund  - Engineering team has given the following inputs for this.

 

Looks like the app is not part of user's tenant and that's why it gives 404 error. Since it is 3P app and already in store he even can't upload package to Teams Developer Portal because appId already exists.

By default, only DevX members have admin privileges over apps part of global store. Even, if user is tenant admin, app Id and tenant Id should be specified in the ECS config. In that case, the tenant admins for the specific tenant will have admin privileges on the app.

 

The tenant admin should file a support ticket to prove that they own the app. After that, we will do a one-time exercising of mapping the app to their tenant, following which the tenant admin will have control over the app.

@Meghana-MSFT 

Thanks for looking into this. Actually, the error we get is 403, not 404.

Anyway, I am admin of the tenant. I can file a support ticket if you want. Actually, I did this already, but the answer I got was they couldn't help me, because it wasn't an Azure/Entra issue, but a Teams store issue. So I should file a support ticket there.

@finrodFelagund - Engineering team has suggested to file a support ticket.
Thanks, as mentioned before I've already filed a support ticket via that channel. Unfortunately, nobody could solve the issue so far. That's why I tried to post in this forum.
We will check this internally and get back to you.

@finrodFelagund - Engineering team has asked for the following info. Please share the below information on microsoftteamsdev@microsoft.com.

 

  • App ID of the published app
  • Tenant ID of the requestor's tenant
  • Email ID 
  • Screenshot of the mail from Partner center when the app was published

Once we have this information, we will also double check internally with store ops team, post which we can provide ownership in TDP.