SOLVED

Sharing app content to stage, Insufficient RSC permission

Visitor

Hello,

 

sharing the content of our app hasn't worked for a week.

Using the Teams WebApp we are getting the following errors in the developer console:

 

CID[main] ShareExtensibleAppButtonContainer: Installed app is undefined or doesn't have authorization
Insufficient RSC permission for appId:'' with isChannelMeeting: false

it worked last month, and nothing was changed from our side.

I tried to set the following permissions, but it has had no effect.

 

"authorization": {
    "permissions": {
      "orgWide": [],
      "resourceSpecific": [
        {
          "name": "MeetingStage.Write.Chat",
          "type": "Delegated"
        },
        {
          "name": "ChannelMeetingStage.Write.Group",
          "type": "Delegated"
        }
      ]
    }
  }

 

could anyone help me to get it working?

 

Thank you

3 Replies
Having the same bug, I tried to use the Meeting App Sample in Visual Studio Code Using Teams Toolkit but the same bug happens.

We can also confirm that we are unable to share any app while in a meeting. This week it stopped working with the same error message. We were able to share our app last week.

best response confirmed by MRoutchkan (Visitor)
Solution

This question is being tracked here - https://stackoverflow.com/questions/73949755/sharing-app-content-to-stage-insufficient-rsc-permissio.... Please check that thread for further updates. Thank you for your understanding.