"Manifest parsing has failed." in Developer Portal

Brass Contributor

I am using the Developer Portal app in Teams.

I got "Manifest parsing has failed." error when click "Preview in Teams" button.


Also I got "App does not have the required permissions for this operation." error after click "x" button.


I have no validation error in the manifest file.

How can I fix it?

60 Replies
@m36five -Could please check the manifest zip in APP Studio ->Validation->Upload manifest package
and then check the exact error.

@Sayali-MSFT The error when I checked the manifest in App Studio was, "Package acceptance validation error: Package Loading Failure Provided add-in package was not understood. Please, make sure that the file being submitted is a valid Office add-in package." But when I downloaded the manifest in App Studio instead of, I was able to test, run, and install it just fine. It's only the Developer Portal that won't allow a preview in Teams.

@m36five - We will provide the information to internal team. We will inform you once we get any update.

@m36fiveAny news regarding this? I'm creating a Teams app and I'm experiencing the exact same issues
App and bot created directly through Developer Portal in Teams and user is Global Admin. Yet still I get the "Manifest parsing has failed." error along side the "App does not have the required permissions for this operation" message.

Steps to reproduce:
1) Create a new app in Developer Portal
2) Enter relevant information
3) Add a bot with a ngrok URL
4) Press the "Preview in Teams" button

All I want is a callback to my local URL to verify that the setup works - but I can't even get that far.
At the moment the whole Teams-app experience seems rather broken :\

@inversiondk - I haven't tried the Developer Portal since my post on June 13. I ended up using the App Studio app in Teams instead of the Developer Portal. Using the App Studio app, I was able to validate the change to my existing app, test my app in Teams, and publish the update. Then, in the Teams Admin center, I approved and pushed the update.

@m36fiveThink I'll give that a try. But this might be short lived as App Studio is set to be retired :\

But for now, I'll try giving it a go. Thanks.

So, becase App Studio has been deprecated and does not work anymore, we have a problem. How to do development when there is no option to install/preview app because of the issue described here?


It does not work for new app created directly in the Developer portal.

@Lukáš NešporYou can sideload your app as a zip-file in Teams by going to "Apps" -> "Manage Your Apps" and then clicking the "Upload an app"-button. This requires that you have the correct permissions in your organization.

For development I simply used a Microsoft Developer account as this gave me Global Admin rights.


If you create an app manifest file through the App Studio and download this as a zip-file, you should be able to use the app. It worked for me at least :)

I have Global Admin rights and I created new app directly in the Developer portal few minutes ago whith the same result.
If your app fails to install then Teams usually offers a link with "Copy error message" or something like that. If you get that link and copies the error message, what does it say?

Once Preview in Teams is clicked these two errors occurs:
- Manifest parsing has failed.
- App does not have the required permissions for this operation


I also tried direct way to install the app using URL{APPID}?installAppPackage=true But it also fails with "Something went wrong."

This way API is called with response {"errorCode":"CreateUserAppDefinitionFailed"}

@Lukáš NešporDon't use the "Preview in Teams"-functionality. It's totally broken (at least it is for me).


1) Create your app manifest using the Developer Portal

2) Download the app as a zip-file:


3) Go to Apps -> Manage your apps -> Upload an app and select your newly created zip-file:




This is the only way I found to install and test my Teams app. Works every time though.


Hope it helps you out as well.

This "simple" way is working :D Thanks!

Hello @karamem0, @__jaco, @Erik Olsson, @m36five, @inversiondk - Sorry for the delay and inconvenience.
Can you please try with "Upload an app" option and check if it's working for you?

We are following with engineering team for the reported bug and let you know the updates.

Hello @karamem0, @__jaco, @Erik Olsson, @m36five, @inversiondk -Right now it only supports first party apps. To workaround this, please use Developer Portal to preview in teams.

@Sayali-MSFT Could you clarify your last post please.

What do you mean by "it only supports 1st party apps"?

Are you suggesting we should use the Preview version of Developer Portal in Teams?


@Erik Olsson - Use Developer Portal to preview in teams.
The different types of apps that your end-users can use in Teams are:

Core apps that are part of Teams.
Other apps created by Microsoft.
Third-party apps by partners (validated by Microsoft).
Custom apps created by your own organization.

Reference Document-Know about apps in Microsoft Teams - Microsoft Teams | Microsoft Docs

@Sayali-MSFT - This entire thread is about how the "Preview in Teams" button fails.

My experience since the beginning of this thread remains the same. A perfectly working custom app with no errors cannot be tested via "Preview in Teams". As suggested earlier in this thread - the workaround is to download the app package from Developer Portal and then Upload as custom app in Teams. This works fine. We'd like the Preview in Teams button to work or be removed. It's causing confusion.

See screenshots when pressing Preview in Teams (same as the first post in this thread.
It's still not working.

Preview in Teams error 1.pngPreview in Teams error 2.png

@Erik Olsson -Engineering team working on this, It will take time to fix. So, workaround this, Use Developer portal.
Reference Video:

@Sayali-MSFT This Developer portal, you mentioned, does not display my apps. I can see only one with really old configuration (no icon, different version, different domain etc.). The rest of apps are not there.


Developer portal directly in Teams behaves differently in Teams App and in Teams in browser.

Windows Teams App (correct list of apps)

Windows Teams AppWindows Teams App


Teams in Browser (missing apps)

Teams in browserTeams in browser


As you can see first app on both screenshots is the same (by App ID) but with different version and updated date. App was renamed but it is published with the same App ID. Btw. Teams in browser display same data as Developer Portal.