"Manifest parsing has failed." in Developer Portal

Brass Contributor

I am using the Developer Portal app in Teams.

I got "Manifest parsing has failed." error when click "Preview in Teams" button.


Also I got "App does not have the required permissions for this operation." error after click "x" button.


I have no validation error in the manifest file.

How can I fix it?

60 Replies

@karamem0 - Can you please share your manifest JSON or zip package, so that we can try it from our end.

It has happened to me also. I'm following the tutorial from and i have a trial developer account with admin rights.


When i want to see the manifest.json it does not appear in the "App package" right pane. If i try to "Preview in Teams" it shows the same error as stated above

posting a photo of what i described



@__jaco - We are unable to repro the issue. It's working fine for us. Could you just try to Download the app package. You get the app package (manifest.json) then just validate the manifest file in Teams => App Studio = > Validation.


Thank you for replying.

This is the manifest file (And I attached the app package zip file).

I want to add a personal tab for the app. The tab URL is sample. Any other URLs causes the same issue.

  "$schema": "",
  "version": "1.0.0",
  "manifestVersion": "1.12",
  "id": "945a7eaf-60e2-4a17-9488-552215189da5",
  "packageName": "",
  "name": {
    "short": "SampleApp",
    "full": "SampleApp"
  "developer": {
    "name": "karamem0",
    "mpnId": "",
    "websiteUrl": "",
    "privacyUrl": "",
    "termsOfUseUrl": ""
  "description": {
    "short": "SampleApp short description",
    "full": "SampleApp full description"
  "icons": {
    "outline": "outline.png",
    "color": "color.png"
  "accentColor": "#FFFFFF",
  "staticTabs": [
      "entityId": "3139441a-ef5c-475f-8779-6d50d57ca5dc",
      "name": "Home",
      "contentUrl": "",
      "websiteUrl": "",
      "scopes": [
      "entityId": "about",
      "scopes": [
  "validDomains": [


@karamem0 - We are tried to repro the issue as per given manifest file. It's working fine for us.

Are you using developer account with admin rights?
Ref Doc:-Manage your apps with the Developer Portal - Teams | Microsoft Docs

I was granted Global Administrator role to my account but I cound not resolve the problem.
What is "admin rights" that you said?
@karamem0 - We were checking it using admin account but we will check it with non-admin user's and let you know the updates.

@karamem0 - We are checking this issue with non-admin account. Getting same issue as you mention above. So, Could you create the Admin account then you check it once?
Ref Doc:- Manage custom app policies and settings - Microsoft Teams | Microsoft Docs

@karamem0-  Did you get chance to try on the above suggested solution?

@karamem0 - Could you please confirm if your issue has resolved or still looking for any help?
I'm sorry for the delay in my reply.
I created new account having administrative role and tried to preview the app, but I could not it.
I tried many times, it rarely succeeds, but it almost always fails.

We are checked it our end. The issue issue is related to Roles. Could you please check it once?
Ref doc:-Assign Azure AD roles to users - Azure Active Directory | Microsoft Docs

Could you please confirm if your issue has resolved with above suggestion or still looking for any help?


When I have changed the App ID, I was enabled to preview the app via and{{app-id}}?installAppPackage=true. But I can't still lanch the app via Developer Portal App (in Microsoft Teams).

I met same issue when I granted Teams Administrator role to the user. Could you please tell me the role is correct?

@karamem0  - Global Administrator role.


I granted Global Administrator, but I could not it.


I found the difference when clicking Preview button.

In my environments, this URL was called to retrieve the manifest file (Base64 encoded).{{app-id}}/manifest

But the result is not same when I called the URL directly (deleted apac).{{app-id}}/manifest

Is this relevant?

1 best response

Accepted Solutions
best response confirmed by karamem0 (Brass Contributor)
@karamem0-We are able to repro that issue , We have raised bug for the same and concerned team is looking into it. We will inform you once we get any update.

View solution in original post