Not able to add supportedHosts property in spfx webpart manifest file

%3CLINGO-SUB%20id%3D%22lingo-sub-2196087%22%20slang%3D%22en-US%22%3ENot%20able%20to%20add%20supportedHosts%20property%20in%20spfx%20webpart%20manifest%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2196087%22%20slang%3D%22en-US%22%3E%3CP%3EI%20wanted%20to%20deploy%20an%20spfx%20webpart%20as%20a%20tab%20in%20MS%20teams.%20I%20have%20created%20an%20spfx%20webpart%20and%20tried%20to%20insert%20%3CSPAN%3E%22%3C%2FSPAN%3E%3CSTRONG%3EsupportedHosts%3A%20TeamsTab%3C%2FSTRONG%3E%3CSPAN%3E%22%3C%2FSPAN%3Eproperty%20in%20webpart%20manifest%20file%20but%20it%20is%20giving%20me%20an%20error%20while%20running%20gulp%20serve.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EError%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3E%3CSPAN%3E%5B16%3A20%3A39%5D%20Error%20-%20%5Bwrite-manifests%5D%20Manifest%20validation%20error%20(.%2Fsrc%2Fwebparts%2FmyFirstTeamTab%2FMyFirstTeamTabWebPart.manifest.json)%3A%20(%23%2F)%20Data%20does%20not%20match%20any%20schemas%20from%20'oneOf'%20(%23%2F)%20Missing%20required%20property%3A%20description%20(%23%2F)%20Missing%20required%20property%3A%20extensionType%20(%23%2FcomponentType)%20No%20enum%20match%20for%3A%20WebPart%20(%23%2F)%20Additional%20properties%20not%20allowed%3A%20supportedHosts%20(%23%2F)%20Missing%20required%20property%3A%20items%20(%23%2F)%20Missing%20required%20property%3A%20rootComponentId%3C%2FSPAN%3E%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20not%20able%20to%20find%20out%20what%20is%20the%20actual%20cause%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESpfx%20version-1.11.0%3C%2FP%3E%3CP%3ENode-12.18.0%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2196087%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

I wanted to deploy an spfx webpart as a tab in MS teams. I have created an spfx webpart and tried to insert "supportedHosts: TeamsTab"property in webpart manifest file but it is giving me an error while running gulp serve.  

 

Error:

[16:20:39] Error - [write-manifests] Manifest validation error (./src/webparts/myFirstTeamTab/MyFirstTeamTabWebPart.manifest.json): (#/) Data does not match any schemas from 'oneOf' (#/) Missing required property: description (#/) Missing required property: extensionType (#/componentType) No enum match for: WebPart (#/) Additional properties not allowed: supportedHosts (#/) Missing required property: items (#/) Missing required property: rootComponentId

 

I am not able to find out what is the actual cause?

 

Spfx version-1.11.0

Node-12.18.0

0 Replies