Not able to add bot app to teams group.

Brass Contributor

We have uploaded the manifest file in teams admin center and tried to add the app to a team group and we are getting the below error while adding the app.

 

Lakshmi_0-1699620817623.png

 

Also we are getting Internal server error in network logs also,

 

Lakshmi_1-1699620858452.png

 

App has been added by admin who has 'Teams Administrator' permission . Is any extra permission needed to add the bot app to teams

7 Replies

Hello Lakshmi- Thanks for raising your query.
Could you please share your manifest package via removing PII data, so that we can verify it?
Also, please share the complete logs or error information, so that we can investigate your issue.

Thanks,

@Sayali-MSFT

 

 Attached the network logs and manifest file,

 

We have collected the logs from the client team admin center where the actual issue was found. In the manifest file we have added the permission ChannelMessage.Read.Group  and manifest file version is 1.11. Below is the error message that we are seeing in payloads. Also, this manifest file is working in many other tenants.

 

Lakshmi_0-1699953974078.png

 

Hello @Lakshmi_145-Thanks for sharing the information. We will test this and let you know the update.

@Lakshmi_145 -

@Lakshmi_145 -We have tested this scenario, with the provided manifest and it is working fine from our end. As you mention for some tenant it is working fine.

We are checking the provided logs with internal team and let you know the update.
SayaliMSFT_0-1700222964625.png

 

@Sayali-MSFT 

 

We have enabled the auto install option in the admin center and after that, we were able to add the app to the team. But we coudnt find the exact reason why it worked like that. Because in all other tennats, this option is disabled and still we were able to add the app to the teams group. 

Lakshmi_0-1700231374109.png

 

@Lakshmi_145-We are checking the issue with the internal team, we will let you know once we have any update.

@Lakshmi_145-We got the reply from engineering team that, the tenant admin needs to check their consent settings.
Please follow: Grant RSC permissions to an app - Teams | Microsoft Learn