ms teams app not listed in publish to org page

Copper Contributor

The app is approved and published to org. But in this page it's not visible.


You can see the bot is approved.


There is no user level policy restriction or anything. There is only one user and its admin.


20 Replies

@Garrykevin - Thanks for reporting your issue.
We will check this at our end and will get back to you.

@Garrykevin -Have you done below steps:-

  1. Sign in to the Teams admin center and access Teams apps > Manage apps.

  2. Select Org-wide app settings.

  3. Under Custom apps, turn on or turn off Allow interaction with custom apps.

    After you allow the use of a custom app, your end-users can find it by selecting 
    Built for your org in the left navigation of Teams store.


    Reference document-Manage custom and sideloaded app policies and settings - Microsoft Teams | Microsoft Learn

@Garrykevin - Could you please confirm if your issue has resolved with with provided suggestions or still looking for any help? Thanks!
Sorry for the late reply. interaction with custom apps is turned on for my account.
But still apps are not listed

@garry675 -We are not able to repro the issue, could you please share the manifest Json, so that we can try it from our end?
Could you please try to upload the manifest using Admin Center and check it once if app is listed or not?

@Sayali-MSFT I was able to access the app by creating similar manifest as my friends. But the built for org page seems to broken.


Screenshot 2023-02-09 at 1.45.20 AM.png

The page was working for sometime after creating the app. And it doesn't work now.



However using the same manifest helps to make the bot to atleast work


manifest.json :

@Sayali-MSFT I was able to make the bot work by trying to create the same manifest, as my teammates working bot. But the built for org pages seems to be broken.


The page was working sometime after app creation and doesn't work now.

Screenshot 2023-02-09 at 1.45.20 AM.png


Screenshot 2023-02-12 at 10.51.53 PM.png


manifest that works.

@garry675 -We are also checking the same manifest but it is showing app in org. with Admin portal and also check with non-admin user it is showing both places.
Teams version-Microsoft Teams Version (64-bit)

@Garrykevin @Sayali-MSFT 

I am facing the same issue. I have uploaded an application (as an admin) to our organisation. While the status is approved, it is not yet published to the "Built for your organisation" section of the store. 


Strangely enough, we have another application (created a while ago), that has exactly the same status in the admin dashboard, but this app is visible in the "Built for your organisation" section of the store. 



Are there any other requirements the app has to meet or steps that we have to take to make the application available in this section?

I am also experiencing this exact issue. This seems like a bug. I spent all weekend trying to get my apps to show up in the Teams app section. This was working earlier this week, but sometime around Friday it stopped working.

@Peter Philips For me they magically showed up this morning. Not really helpful/promising, but let's hope it was an internal issue that has now been solved.

@Tom_Hartogs glad you got it to work!


I'm still having trouble though. I created a raw "testapp" from the Developer portal and that is now finally showing after a day (why so long?). However, the app that I want to appear in Teams still doesn't after waiting a full weekend. It shows as identical to the "testapp". @Sayali-MSFT any ideas? Would really appreciate some help, thank you!

Screenshot 2023-12-11 at 8.25.17 AM.pngScreenshot 2023-12-11 at 8.25.36 AM.pngScreenshot 2023-12-11 at 8.25.48 AM.png


@Peter Philips - It is normal for your app to take some time to appear in the Teams store after you have made changes or created a new app. According to the documentation, it can take up to one business day for your app to be available in the Teams store. So, the delay you experienced with your "testapp" appearing is within the expected timeframe.

@Sayali-MSFT So, is this the expected behavior when developing an app? We often find that we need to remove the app and re-add it to make sure we are working with the latest version and to clear out any issues. Having to wait a full day each time we need to reload the app into our tenant really slows down development! Is there perhaps another way we should be pushing updates to our apps when they are in development?

@Peter Philips -We are also trying the same scenario, the app is showing after one hour as per expected timeline.

also yes, there is another way to push updates to your apps when they are in development without having to wait for a full day. You can use sideloading to install and update your app directly in your Teams tenant.

Sideloading allows you to install custom apps directly into your Teams environment without going through the app submission and approval process. This is useful for development and testing purposes.

To enable sideloading for your tenant, follow these steps:

  1. Sign in to the Teams admin center with your test tenant credentials.

  2. Go to Teams apps > Manage apps.

  3. At the top right, select Org-wide app settings.

  4. Under Custom apps, turn on the Interaction with custom apps toggle and Save.

Once sideloading is enabled, you can upload and install your custom app directly into your Teams environment. Here's how you can update your app using sideloading:

  1. Make the necessary changes to your app.

  2. Package your updated app as a zip file.

  3. In the Teams client, go to the Apps section on the left-hand side.

  4. Click on the Upload a custom app button at the bottom of the app list.

  5. Select the zip file of your updated app and click Open.

  6. Your app will be installed and updated in your Teams environment.

By using sideloading, you can quickly update your app during development without having to wait for the app to be published in the Teams store. This allows for faster iteration and testing of your app.

It's important to note that sideloading is only available for development and testing purposes. Once your app is ready for production, you will need to go through the app submission and approval process to make it available to all Teams users.

For more information on sideloading and app distribution, you can refer to the Microsoft Teams documentation.

@Sayali-MSFT Thank you so much for your detailed response. I really appreciate it. 


That said, we are unfortunately continuing to encounter issues. Please let me explain. 


While the sideloading works for static tabs, channel tabs, and connectors, it does not work for bot integrations. We noticed that when we sideload the app and install a bot, no "Enterprise application" is created from our App registration which is what happens when installed through Org installation and publishing. As a result, a number of endpoints needed for bot framework functionality do not work during sideloading and result in permission errors presumably because there is no way to grant admin consent. 


Do you have any advice on this? Is it expected that Teams app development for bots cannot work through sideloading? Or is there other expectation? Thank you!

@Sayali-MSFT - I'm having the same issue

I uploaded the app in the teams admin page (, and checked that my org has the correct org-wide app settings to allow custom apps.

After I uploaded the app, it didn't appear in the "built for your org" section.

I removed it and uploaded it again a couple of times and it didn't work. I also waited for 1-2 business days to appear but it still nothing happens.

Now, the "built four your org" section is missing entirely.

Screenshot 2023-12-21 at 15.23.06.png

The app has the following configuration:
- Assignment Status: Everyone can install
- Published status: Published
- App status: Allowed

In the Teams App -> Apps -> Manage your Apps -> Pending Requests section, it has the status "Approved".

Screenshot 2023-12-21 at 15.16.43.png

Do you have any advice on this ? What am I missing here ?

Thanks !

I'm also getting hammered with this. When I upload my app (or install it from the Developer Portal into my tenant).

If I directly send people to the app deep link location, it allows them to "Request" permissions, but even though I've already given permissions from the Teams Admin side, and have everything set to open permissions, it gets stuck at that "Request permission" page and won't let them actually interact with the bot.
Hello @Garrykevin, we tried uploading the app and it is working fine from our end. However it may take 3-5 business days for the app to be visible in publish to org page.
Make sure you are following the steps suggested by Microsoft.