Microsoft Teams Graph API Error

%3CLINGO-SUB%20id%3D%22lingo-sub-1061052%22%20slang%3D%22en-US%22%3EMicrosoft%20Teams%20Graph%20API%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061052%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EI%20am%20using%20Microsoft%20Graph%20to%20Clone%20a%20team%20and%20I%20am%20getting%20Not%20Found%20errors.%20I%20used%20the%20Graph%20Explorer%20to%20get%20a%20list%20of%20teams%20that%20I%20am%20a%20member%20of%20and%20selected%20this%20one%20to%20clone.%20My%20flow%20does%20contain%20the%20proper%20Client%2C%20Tenant%2C%20and%20Client%20Secret%20information%20and%20I%20have%20registered%20my%20app%20in%20Azure%20with%20the%20correct%20permissions.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Etemplate%3A%20%22id%22%3A%20%22cd6239d4-4d21-48d8-93f7-f17fae351871%22%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22%3C%2FSPAN%3E%3CSPAN%3EdisplayName%22%3A%20%22Template_Team%22%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22description%22%3A%20%22This%20is%20the%20base%20template%20for%20new%20Teams.%22%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22internalId%22%3A%20null%2C%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22webUrl%22%3A%20null%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22isArchived%22%3A%20false%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22memberSettings%22%3A%20null%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22guestSettings%22%3A%20null%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22messagingSettings%22%3A%20null%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22funSettings%22%3A%20null%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%22discoverySettings%22%3A%20null%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIn%20my%20workflow%2C%20I%20am%20calling%20the%20following.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F161165iF5BC659C10DB2397%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EPOST%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fteams%2Fa30b9536-631b-4fe9-ad1c-836c00f17dc7%2Fclone%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fteams%2Fa30b9536-631b-4fe9-ad1c-836c00f17dc7%2Fclone%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EGetting%20the%20following%20error%20%7B%20%22error%22%3A%20%7B%20%22code%22%3A%20%22ResourceNotFound%22%2C%20%22message%22%3A%20%22Invalid%20version%3A%20teams%22%2C%20%22innerError%22%3A%20%7B%20%22request-id%22%3A%20%2224ee407c-7baa-4e2c-a88a-77af52424150%22%2C%20%22date%22%3A%20%222019-12-11T18%3A04%3A04%22%20%7D%20%7D%20%7D%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1061052%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1064036%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20Graph%20API%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1064036%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F3254%22%20target%3D%22_blank%22%3E%40Greg%20Stover%3C%2FA%3E%26nbsp%3B%2C%20We%20tried%20clone%20a%20Team%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fteam-clone%3Fview%3Dgraph-rest-1.0%23request%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fteam-clone%3Fview%3Dgraph-rest-1.0%23request%3C%2FA%3E%2C%20we%20were%20successfully%20able%20to%20clone%20team%2C%20Could%20you%20please%20check%20your%20request%20body%2C%20what%20you%20are%20sending%20for%20clone%2C%20I%20think%20the%20issue%20is%20with%20your%20request%20body.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Regular Visitor

I am using Microsoft Graph to Clone a team and I am getting Not Found errors. I used the Graph Explorer to get a list of teams that I am a member of and selected this one to clone. My flow does contain the proper Client, Tenant, and Client Secret information and I have registered my app in Azure with the correct permissions.

 

template: "id": "cd6239d4-4d21-48d8-93f7-f17fae351871",

"displayName": "Template_Team",

"description": "This is the base template for new Teams.",

"internalId": null, 

"webUrl": null,

"isArchived": false,

"memberSettings": null,

"guestSettings": null,

"messagingSettings": null,

"funSettings": null,

"discoverySettings": null 

 

In my workflow, I am calling the following.

 

clipboard_image_0.png

 

 

POST https://graph.microsoft.com/teams/a30b9536-631b-4fe9-ad1c-836c00f17dc7/clone 

 

Getting the following error { "error": { "code": "ResourceNotFound", "message": "Invalid version: teams", "innerError": { "request-id": "24ee407c-7baa-4e2c-a88a-77af52424150", "date": "2019-12-11T18:04:04" } } }

1 Reply
Highlighted

@Greg Stover , We tried clone a Team https://docs.microsoft.com/en-us/graph/api/team-clone?view=graph-rest-1.0#request, we were successfully able to clone team, Could you please check your request body, what you are sending for clone, I think the issue is with your request body.