Microsoft Graph Toolkit not working in desktop & browser versions of Teams

%3CLINGO-SUB%20id%3D%22lingo-sub-2587389%22%20slang%3D%22en-US%22%3EMicrosoft%20Graph%20Toolkit%20not%20working%20in%20desktop%20%26amp%3B%20browser%20versions%20of%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2587389%22%20slang%3D%22en-US%22%3E%3CP%3EWhat%20do%20I%20need%20to%20do%20to%20get%20the%20toolkit%20to%20work%20as%20expected%20in%20both%20desktop%20and%20browser%20versions%20of%20Teams%3F%20We've%20followed%20the%20guidance%20and%20documented%20instructions%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Ftoolkit%2Fget-started%2Fbuild-a-microsoft-teams-tab%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Eon%20this%20page%3C%2FA%3E%26nbsp%3Bbut%20the%20components%20we%20have%20added%20do%20not%20appear%20to%20be%20functioning%20at%20all.%20We%20are%20adding%20the%20code%20to%20an%20existing%20project%20that%20uses%20a%20channel%20tab%20rather%20than%20creating%20a%20new%20project%20and%20we%20aren't%20sure%20if%20that's%20the%20reason%20why%20it's%20not%20working%20for%20us.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20summarise%20the%20issues%3A%3C%2FP%3E%3COL%3E%3COL%3E%3CLI%3EThere%20is%20a%20difference%20in%20behaviour%20when%20Teams%20is%20run%20in%20the%20desktop%20app%20and%20when%20it%20is%20run%20in%20the%20browser%3B%3C%2FLI%3E%3CLI%3EIn%20the%20desktop%20app%2C%20the%20login%20popup%20window%20appears%20to%20be%20behaving%20as%20expected%2C%20but%20the%20login%20routine%20returns%20a%20failure%20and%20the%20user%20is%20never%20logged%20in%20to%20Graph%20API%3B%3C%2FLI%3E%3CLI%3EIn%20the%20web%20browser%2C%20the%20login%20popup%20window%20appears%20to%20be%20behaving%20as%20expected%2C%20and%20the%20%3CMGT-LOGIN%3E%20component%20shows%20the%20user%E2%80%99s%20real%20name%20after%20login.%26nbsp%3B%20However%2C%20the%20other%20components%20do%20not%20appear%20to%20work%2C%20and%20behave%20as%20they%20did%20when%20the%20user%20was%20not%20logged%20in.%26nbsp%3B%20The%20agenda%20component%20is%20not%20visible%2C%20the%20channel%20picker%20component%20cannot%20find%20any%20channels%20to%20display%2C%20and%20the%20person%20component%20shows%20a%20blank%20user%20icon%20and%20nothing%20else.%3C%2FMGT-LOGIN%3E%3C%2FLI%3E%3C%2FOL%3E%3C%2FOL%3E%3CP%3EAnyone%20know%20what%20the%20problem%20could%20be%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2587389%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

What do I need to do to get the toolkit to work as expected in both desktop and browser versions of Teams? We've followed the guidance and documented instructions on this page but the components we have added do not appear to be functioning at all. We are adding the code to an existing project that uses a channel tab rather than creating a new project and we aren't sure if that's the reason why it's not working for us. 

 

To summarise the issues:

    1. There is a difference in behaviour when Teams is run in the desktop app and when it is run in the browser;
    2. In the desktop app, the login popup window appears to be behaving as expected, but the login routine returns a failure and the user is never logged in to Graph API;
    3. In the web browser, the login popup window appears to be behaving as expected, and the <mgt-login> component shows the user’s real name after login.  However, the other components do not appear to work, and behave as they did when the user was not logged in.  The agenda component is not visible, the channel picker component cannot find any channels to display, and the person component shows a blank user icon and nothing else.

Anyone know what the problem could be?

0 Replies