Mgmt.AppCatalog.LOBApp.Upload.BadRequest.UnknownTeamsAppManifestExceptionType error has occured

Brass Contributor

I cannot upload custom app into organization because Mgmt.AppCatalog.LOBApp.Upload.BadRequest.UnknownTeamsAppManifestExceptionType error has occured.


What I tried:

  • I tried to upload same app to other tenant but got same error.
  • I tried to upload other app but got same error.

What happened?

50 Replies

@karamem0 - We are investigating your query. We will inform you once we have any update.

One of my clients has just reported having this error when uploading an app on 10-April-2022 too. Not seen this error before.
I'm also getting the same error trying to upload a custom app for testing.
It's passing the app validator perfectly:
Having the same issue, when trying to upload an app to Teams admin center. Also trying to publish an app directly in Teams for preview does not work.
Facing this issue while uploading the manifest.

appPackage call is failing with UnknownTeamsAppManifestExceptionType
Same here, we get UnknownTeamsAppManifestExceptionType when trying to upload a custom app.
The same app worked about a month ago.

@karamem0We are also facing this issue when uploading the custom APP.
It was working fine till last Friday (8/April) ! Looks like some new changes in MSFT is breaking the existing feature.

Same here, we encounter UnknownTeamsAppManifestExceptionType when trying to upload a custom app.
It used to work not long ago..
I did a tweet to support to see if we can get a status update on this issue. Had a deployment planned for weeks to happen this morning :(
@karamem0 - Could you please share your manifest file zip to check at our end?
We are experiencing too this issue; we can provide a manifest. Can you please contact with us via email, since we can't post files here.

I'm facing the same issue with a perfectly good Manifest file which we've successfully used before and passes the app validation ( with no issues.
@Nivedipa-MSFT any updates?

@karamem0 - We are able to repro this issue. We have raised a bug for it. We will inform you once we have any update.



Do we have an update on the issue?


we encountered this on our latest installation of the app



We have the same issue since last friday. We tried from VS Code Teams Toolkit and in Teams admin.


same issue for us since this morning. looking forward to get any news.
1 best response

Accepted Solutions
best response confirmed by karamem0 (Brass Contributor)

karamem0 - This issue has fixed now. Could you please check once.

View solution in original post