Localization of App

Brass Contributor


Hi,
I tried to update the manifest.json file to support localization.

 

{
    "$schema": "https://developer.microsoft.com/en-us/json-schemas/teams/v1.16/MicrosoftTeams.schema.json",
    "manifestVersion": "1.16",
    "version": "1.0.0",
    "id": "3fb32313-adb1-4a04-8c35-f3ad7c0f0188",
    "packageName": "com.microsoft.teams.extension",
    "localizationInfo": {
        "defaultLanguageTag": "fr-ca",
        "additionalLanguages": [
            {
                "languageTag": "fr-ca",
                "file": "fr-ca.json"
            }
        ]
    },
    "developer": {
        "name": "Teams App, Inc.",
        "websiteUrl": "https://localhost:53000",
        "privacyUrl": "https://localhost:53000/index.html#/privacy",
        "termsOfUseUrl": "https://localhost:53000/index.html#/termsofuse"
    },
    "icons": {
        "color": "color.png",
        "outline": "outline.png"
    },
    "name": {
        "short": "Localization",
        "full": "Localization App"
    },
    "description": {
        "short": "Localization App for Microsoft Teams",
        "full": "This sample app provides a very simple localization app. You can extend this to add more content and capabilities."
    },
    "accentColor": "#FFFFFF",
    "bots": [],
    "composeExtensions": [],
    "configurableTabs": [],
    "staticTabs": [
        {
            "entityId": "index",
            "name": "Personal Tab",
            "contentUrl": "https://localhost:53000/index.html#/tab",
            "websiteUrl": "https://localhost:53000/index.html#/tab",
            "scopes": [
                "personal"
            ]
        }
    ],
    "permissions": [
        "identity",
        "messageTeamMembers"
    ],
    "validDomains": [
        "localhost:53000"
    ],
    "webApplicationInfo": {
        "id": "254c5630-0ff0-4ec5-a7e8-824f0762f7e6",
        "resource": "api://localhost:53000/254c5630-0ff0-4ec5-a7e8-824f0762f7e6"
    }
}

 

But when I am adding the app to the teams, the initial window content is not showing the default language set. As in this case I set fr-ca as a default language. NOTE: I am running this app locally

ray2408_0-1718101326846.png

 




 

0 Replies