SOLVED

Just one of our Teams can't show or hide channels

%3CLINGO-SUB%20id%3D%22lingo-sub-1902504%22%20slang%3D%22en-US%22%3EJust%20one%20of%20our%20Teams%20can't%20show%20or%20hide%20channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1902504%22%20slang%3D%22en-US%22%3E%3CP%3EGood%20day!%3CBR%20%2F%3ESome%20coworkers%20have%20a%20team%20with%20about%2050%20channels%20where%20no%20one%20can%20show%20or%20hide%20any%20of%20the%20channels.%20I%20did%20a%20little%20troubleshooting%20on%20this%20already%20but%20I%20just%20can't%20figure%20out%20anything%20to%20make%20it%20work.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20error%20message%20is%20%22Couldn't%20show%20%5Bchannel%20name%5D.%20Try%20again.%22%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Jack_Eidsmsness_0-1605724587007.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F234457iC923F5E82F1030F7%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Jack_Eidsmsness_0-1605724587007.png%22%20alt%3D%22Jack_Eidsmsness_0-1605724587007.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20happens%20in%20the%20web%20client%20and%20app%20alike.%20It%20happens%20for%20everyone%20who%20tries%20to%20show%20any%20of%20the%20channels.%20When%20I%20try%20to%20hide%20a%20channel%20that%20was%20shown%20before%2C%20it%20will%20literally%20be%20hidden%2C%20but%20it%20still%20shows%20an%20error%20message%20saying%20that%20it%20couldn't%20hide%20the%20channel.%20Those%20are%20the%20only%20ones%20I%20can%20then%20%22show%22%20again%2C%20but%20I%20think%20it%20was%20not%20saving%20the%20setting%20to%20hide%20it%20in%20the%20first%20place.%20I%20assume%20if%20I%20quit%20and%20started%20again%2C%20it%20would%20not%20be%20hidden.%3CBR%20%2F%3E%3CBR%20%2F%3EBecause%20I'm%20also%20a%20web%20developer%2C%20I%20got%20some%20more%20info%20from%20the%20browser%20developer%20console.%3CBR%20%2F%3EI%20can%20see%20a%20little%20bit%20more%20error%20information%20in%20the%20server's%20JSON%20response%3A%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%7B%22errorCode%22%3A201%2C%22message%22%3A%22User%20is%20no%20longer%20in%20thread%20roster.%22%7D%3CBR%20%2F%3E%3CBR%20%2F%3EThat%20is%20the%20message%20body%20of%20a%20failed%20PUT%20to%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22url-scheme%22%3E%26nbsp%3B%26nbsp%3B%20https%3CBR%20%2F%3E%3C%2FSPAN%3E%26nbsp%3B%26nbsp%3B%3CSPAN%20class%3D%22url-host%22%3E%20ng.msg.gcc.teams.microsoft.com%3CBR%20%2F%3E%26nbsp%3B%26nbsp%3B%20%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-filename%22%3E%2Fv1%2Fusers%2FME%2Fconversations%2F%7Bchannel-id%7D%2Fproperties%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-chars%22%3E%3F%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-params%22%3E%3CSPAN%20class%3D%22url-params-name%22%3Ename%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-chars%22%3E%3D%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-params-value%22%3Efavorite%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-chars%22%3E%26amp%3B%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-params%22%3E%3CSPAN%20class%3D%22url-params-name%22%3ErequirePermanentJoinedState%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-chars%22%3E%3D%3C%2FSPAN%3E%3CSPAN%20class%3D%22url-params-value%22%3Etrue%3C%2FSPAN%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3EI%20broke%20up%20that%20URL%20and%20replaced%20the%20literal%20channel%20id%20with%20%7Bchannel-id%7D%20because%20I%20know%20it%20wouldn't%20be%20the%20clickable%20kind%2C%20anyway.%20I%20grabbed%20it%20from%20the%20Network%20tab%20of%20the%20developer%20console.%20The%20HTTP%20status%20of%20the%20reply%20was%20400.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20user%20experience%20is%20that%20it%20just%20says%20it%20failed%20and%20to%20try%20again%2C%20like%20in%20the%20screen%20cap.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20is%20not%20a%20new%20team%2C%20but%20if%20it%20makes%20a%20difference%2C%20I%20added%20a%20bunch%20of%20channels%20last%20month%2C%20and%20a%20bunch%20of%20members%20started%20using%20it%20more%2C%20today%2C%20and%20just%20encountered%20the%20show%2Fhide%20problem.%20I%20have%20personally%20shown%20and%20hidden%20channels%20last%20month%20on%20this%20team%2C%20but%20I%20can%20not%20today.%20I%20am%20in%20many%20other%20teams%20in%20this%20org%2C%20whose%20channels%20can%20be%20shown%20and%20hidden%20normally.%26nbsp%3B%20No%20one%20who%20has%20tested%20in%20this%20one%20team%20can%20show%20or%20hide%20any%20channels%20and%20I'm%20unaware%20of%20any%20other%20teams%20that%20have%20the%20same%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1902504%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1905815%22%20slang%3D%22en-US%22%3ERe%3A%20Just%20one%20of%20our%20Teams%20can't%20show%20or%20hide%20channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1905815%22%20slang%3D%22en-US%22%3EI%20have%20not%20found%20this%20one%20myself%20and%20best%20you%20can%20do%20here%20is%20to%20open%20a%20support%20ticket%20and%20share%20with%20support%20all%20this%20valuable%20information%20you%20have%20posted%20here%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1905878%22%20slang%3D%22en-US%22%3ERe%3A%20Just%20one%20of%20our%20Teams%20can't%20show%20or%20hide%20channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1905878%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F763202%22%20target%3D%22_blank%22%3E%40Jack_Eidsmsness%3C%2FA%3E%2C%20Could%20you%20please%20check%20the%20settings%20for%20your%20teams%20channel%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1907535%22%20slang%3D%22en-US%22%3ERe%3A%20Just%20one%20of%20our%20Teams%20can't%20show%20or%20hide%20channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1907535%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F371090%22%20target%3D%22_blank%22%3E%40Trinetra-MSFT%3C%2FA%3EThanks%20for%20your%20reply!%3CBR%20%2F%3E%3CBR%20%2F%3EI%20looked%20through%20a%20lot%20of%20settings%2C%20and%20nothing%20seemed%20to%20really%20apply.%20I%20can't%20remember%20everything%20I%20tried%2C%20but%20one%20thing%20I%20did%20test%20is%20changing%20the%20setting%20for%20whether%20a%20channel%20is%20shown%20by%20default%2C%20and%20adding%20and%20removing%20members%20to%20see%20if%20the%20automatic%20setting%20worked%20differently%20from%20the%20manual%20change%20.%20.%20.%20but%20it%20did%20not.%3CBR%20%2F%3E%3CBR%20%2F%3EMore%20importantly%20though%2C%20it%20went%20back%20to%20normal.%20I%20don't%20know%20whether%20a%20person%20fixed%20it%20or%20if%20it%20was%20totally%20automatic%20self%20correction%20inside%20the%20system%2C%20but%20it%20is%20working%20now.%20I%20suspect%20it%20is%20best%20characterized%20as%20a%20system%20level%20problem%20that%20only%20affected%20certain%20teams%20by%20coincidence.%20In%20the%20intervening%20time%2C%20I'd%20been%20informed%20of%20the%20same%20problem%20happening%20to%20a%20number%20of%20other%20teams.%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%2C%20all%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Good day!
Some coworkers have a team with about 50 channels where no one can show or hide any of the channels. I did a little troubleshooting on this already but I just can't figure out anything to make it work.

The error message is "Couldn't show [channel name]. Try again."

Jack_Eidsmsness_0-1605724587007.png

 

This happens in the web client and app alike. It happens for everyone who tries to show any of the channels. When I try to hide a channel that was shown before, it will literally be hidden, but it still shows an error message saying that it couldn't hide the channel. Those are the only ones I can then "show" again, but I think it was not saving the setting to hide it in the first place. I assume if I quit and started again, it would not be hidden.

Because I'm also a web developer, I got some more info from the browser developer console.
I can see a little bit more error information in the server's JSON response:


    {"errorCode":201,"message":"User is no longer in thread roster."}

That is the message body of a failed PUT to

   https
   ng.msg.gcc.teams.microsoft.com
  
/v1/users/ME/conversations/{channel-id}/properties?name=favorite&requirePermanentJoinedState=true

I broke up that URL and replaced the literal channel id with {channel-id} because I know it wouldn't be the clickable kind, anyway. I grabbed it from the Network tab of the developer console. The HTTP status of the reply was 400.

The user experience is that it just says it failed and to try again, like in the screen cap.

This is not a new team, but if it makes a difference, I added a bunch of channels last month, and a bunch of members started using it more, today, and just encountered the show/hide problem. I have personally shown and hidden channels last month on this team, but I can not today. I am in many other teams in this org, whose channels can be shown and hidden normally.  No one who has tested in this one team can show or hide any channels and I'm unaware of any other teams that have the same problem.

4 Replies
best response confirmed by Jack_Eidsmsness (Occasional Contributor)
Solution
I have not found this one myself and best you can do here is to open a support ticket and share with support all this valuable information you have posted here

@Jack_Eidsmsness, Could you please check the settings for your teams channel? 

@Trinetra-MSFTThanks for your reply!

I looked through a lot of settings, and nothing seemed to really apply. I can't remember everything I tried, but one thing I did test is changing the setting for whether a channel is shown by default, and adding and removing members to see if the automatic setting worked differently from the manual change . . . but it did not.

More importantly though, it went back to normal. I don't know whether a person fixed it or if it was totally automatic self correction inside the system, but it is working now. I suspect it is best characterized as a system level problem that only affected certain teams by coincidence. In the intervening time, I'd been informed of the same problem happening to a number of other teams.

Thanks, all

@Jack_Eidsmsness , Glad this is solved now, it can happen if certain level of changes is going in your organization.