Images sent by chat bot not shown after Teams update

Copper Contributor

We have a chat bot that can send plots of measurement data as attachments. Since a Teams update today of my Windows client app (to, the pictures are not shown anymore. The outline is still visible.


Adaptive cards that contain e.g. tables work fine, the problem is only with images.


Another error that appears since today is displayed in the login card, see below. The login clearly works, since the bot can use delegated authority to access data from our SharePoint. But it always complains about being unable to reach the app.


The bot works perfectly fine using the web client, my mobile, or a colleagues' computer (with the old Teams version), so I'm thinking it must be the client app.

The chat bot is sideloaded using a zip file (upload custom app), it is a development version. The relevant domains (* for authentication, * for the bot webserver) are added to the validDomains attribute in the manifest.


Picture missing:




Login error:





37 Replies
Could you share the Adaptive card minimal JSON to repro? Or the version of Adaptive card you have used?

I would like you to share the bot Id and timestamp when you faced the issue. I will look into the logs. Also follow this to see if you getting any error in console -



I get the following errors in the console:



The images are not sent as AdaptiveCards (at least not explicitly), but rather as base64 encoded string attachment like in this example (_get_inline_attachment):


Adaptive cards with tables etc. work fine, except for the timeout error in the login card.


I attached the json response using bot framework emulator.

I'll send the bot id in a private message.

@Bertrand_Kerres - We have tried ourselves in the same version and we are not facing any issue. Could you please confirm, if your colleagues having same version, for them it's not working?



We are looking into the bot logs, I will update you if I find any.
Have you tried signing out and login back? (it might solve the issue)




I checked with some colleagues:
Me and three others are now on version, and three of us four face this issue. It works for one of us.
Another colleague is on and it works.

I tried logging out and in again, it didn't change it unfortunately.
If I use the "Share to Outlook" function, the image gets displayed in the new window:



We use an OAuth prompt.
Have you tried sending another image? With the same method? Is all not working for you. In OAuth prompt, Is your sign-in is getting complete before timeout mention in it?
We have a repro at our end for the image rendering issue , we are investigating it. I am still unable to repro the OAuth prompt issue.
Other images don't get rendered as well, I guess in your reproduction it will also be image-independent.
For the OAuth prompt, the timeout is mentioned directly after the login is complete.
We have raised a bug for inline attachment issue. We are trying to figure out what could be causing Unable to reach app. Concerned team is looking into it.
Hi MS Experts,

We are having issues in viewing the attachment in Zbot over teams client only. This works fine on teams web version. Requested for help. Thanks
Could you please create a new question with explanation and repro steps?
Where to creat that??
@1990- Go to -
Start a new discussion and add label as Microsoft Teams.

Is you issue started happening after recent update? else it might be a code bug. In that case it would be better to contact the respective dev.
We have raised another bug for OAuth prompt, internal team is looking into it. I will update you once it is fixed.
Request you to explain about OAuth bug pls?
That reply is supposed for @Bertrand_Kerres
I understand that reply ment for @bertrand moreover I wish to know OAuth bug. Request you to explain abit pls?

@Bertrand_Kerres @HunaidHanfee-MSFT Hello, we had the same problem, but as of today without making any changes with the teams version of 7/10/2021 the images began to be sent correctly, but when clicking on them they do not open, on the web and mobile app open correctly


teams desktop



Teams Web


I do not have a previous version available to test, but this worked and it stopped working a few days ago together with the shipment without any change on our part, any ideas

Thank You