Images in Adaptive Cards in New Teams Client not showing

Copper Contributor

Hello Community,

 

I've encountered an issue with Teams Webhook Connector where images in Adaptive Cards are not displaying correctly in the New Teams Client, although they work as expected in the classic version.

Our clients have reported that while messages are visible, the images fail to appear. This problem does not occur in the classic Teams client or when viewed in a browser, which I presume is utilizing the classic client as well.

 

To clarify, I'm using the latest Adaptive Cards version (v1.5) compatible with Teams, and this issue is consistent across both Windows and Apple versions of the New Teams Client. Unfortunately, there seems to be no information available about this compatibility issue in the Adaptive Cards documentation or designer tool.

 

Below is a simple Adaptive Card JSON that illustrates the problem:

 

{
    "type": "AdaptiveCard",
    "body": [
        {
            "type": "TextBlock",
            "size": "Medium",
            "weight": "Bolder",
            "text": "This is a headline"
        },
        {
            "type": "Image",
            "url": "https://img.cdn-pictorem.com/uploads/collection/D/DN4DFF8JRC/900_Nature-Art_colorful--paintings.jpg",
            "width": "300px"
        }
    ],
    "$schema": "http://adaptivecards.io/schemas/adaptive-card.json",
    "version": "1.5"
}

 

 

For visual reference, here is how the card renders in both clients:

 

Classic Teams Client:

Screenshot 2023-11-09 at 11.52.25.png

New Teams Client:

Screenshot 2023-11-09 at 11.52.18.png

I have not found a workaround yet and would greatly appreciate guidance on how to resolve this issue. Any suggestions or updates regarding the new client's support for Adaptive Cards would be very helpful.

Thank you.

 

Best regards

16 Replies
There is a bug raised for this issue, we will keep you posted on the updates. The same issue has been posted here https://techcommunity.microsoft.com/t5/teams-developer/image-inserted-in-incoming-webhook-is-not-wor... earlier.

@Meghana-MSFT thank you very much. I attempting searching for this issue among the community but failed to find the other post you referenced to.

I hope this will be fixed quickly. In the meantime I'll forward your update to my client

@emilSociuu 

 

The cause is pretty clear. 

Compared to Teams Classic the new Teams client (including Teams on the web with the new Teams) extends non-public hosted pictures with a "&v=1" at the of the picture URL. That's the issue. 

 

Here is an example: 

TobiasAT_0-1702380750342.png

 

Public-hosted pictures (like the images from the stock gallery) are not affected. 

@Meghana-MSFT 

I think the development team made a mistake and should use ? instead &, if they want to force a cache update. Then the picture will be displayed like in Teams Classic. 

What an annoying bug. I hope it gets fixed soon.

This issue is fixed now. We have verified the fix in new Teams. 

MeghanaMSFT_0-1704871212461.png

 

@Meghana-MSFT 

Is it possible that the bug has returned?
I currently have this discrepancy between the Teams client and the display in the web browser:

 

Screenshot 2024-01-31 095917.png

 

@Capcom24 - We see that it is working in web browser as well.

MeghanaMSFT_0-1706695762064.png

The client version is 1415/24010419114.

thank you very much for your quick reply.
I think there has been a misunderstanding. Everything is fine in the web browser. The image and the background image are displayed here. The problem is in the Teams client. Could there still be an error here?

@Capcom24 - Its working in Teams client as well.

 

MeghanaMSFT_0-1706720248228.pngMeghanaMSFT_1-1706720283840.png

 

@Meghana-MSFT 

Thanks for the tip. I have just updated my Teams client and unfortunately the Adapative Card is still displayed without images. As I said, everything is fine in the web browser. Could the difference between our two versions be due to the region (Germany in my case)?

 

Bild2.png

 

This is also affecting me, tried to setup new adaptive cards for Azure DevOps notifications, but images do not work on "New teams", they do work on web browser version...
We are checking this internally, we will get back to you.
Yup, same for me. Tried several times today and while appearing in the Adaptive Card Designer, They do not show in New Teams.

@Shaun Tukuafu 

 

I have the same problem. I'm sitting for 4 days to find the solutions. 

Zrzut ekranu 2024-02-15 o 17.36.37.pngZrzut ekranu 2024-02-15 o 17.36.29.png

Moreover then I want to use FTP connector to send to my server images, but after transfer images were broken.

Zrzut ekranu 2024-02-15 o 17.34.06.png

 

And see for example picture: https://sniezek.eu/urk/1_01YOQJUKTRPPJAQUBL6REZKW2ZKCP2SDQ6.jpg

@Meghana-MSFT 

 

I have the same problem (please se below) my issue 

 

If I put external link, images are showing on adaptive cards,

{
  "type": "Image",
  "url": "https://www.kartelmedia.co.uk/wp-content/uploads/2022/06/Zrzut-ekranu-2022-06-5-o-22.03.51.png"
}

Zrzut ekranu 2024-02-15 o 21.06.59.png

 

 but if I put sharepoint/onedrive image link - images are not showing

{
  "type": "Image",
  "url": "@{outputs('sharepoint_attachement_list')?['body/AbsoluteUri']}"
}

Zrzut ekranu 2024-02-15 o 17.36.29.png

the same link is connected to action.openUrl and works properly here. If I paste the image address into the browser, it will also be displayed in the browser.

 

I set full access for everyone for the image - it doesn't work either.

 

It doesn't matter if I inserted an image from SharePoint or OneDrive, it doesn't show up at all.

 

What is wrong, what I do wrong?

I can confirm this behavior and don't think you're doing anything wrong. It must be a misbehavior in the Teams client. In the past, my application (PowerAutomate with Adaptive Card) worked perfectly in the old Teams client. In the web browser anyway. Unfortunately, all we can do at the moment is tell users to use Teams in the web browser for this application. I hope that Microsoft will fix this problem soon...