Image Gateway in Adaptive Cards in Webclient changed and fails to load images

Brass Contributor

I have a bot that uses adaptive cards as messages and renders some images within the cards.

So far this worked perfectly however starting with last Friday, I noticed that the image links in all newly issued cards are broken, while the previously issued cards have working image links. This is only happening in the web client. The desktop client works fine as also the IOS client.

Turns out, that the difference is in the image gateway. It used to be:


But now it is


 When I call the first link, the image loads perfectly, when I call the second I get a 


<Message>Authorization has been denied for this request.</Message>


Please note that in the json of the adaptive card that my bot sends, there is no image gateway included but just the raw link. So the gateway is added by the rendering logic within Teams.

What do I need to do so my adaptive card can show the images again?

Where can I get notice of such changes before they affect my application?


7 Replies

Hi @jocsch,


Thanks for reaching out to us.
We have already started checking the issue internally and we will update you ASAP.

Hi @jocsch,


I have gone through your issue, as we need to test the adaptive card to know how it renders, we would request you to share us the manifest json.

@Rama-MSFT Do you have an email address I can send it to?



Could you please write to us at

Any recommendation? I have seen fluctuating behaviour in the webclient in the last weeks. Sometimes it worked, sometimes it doesn't

However today the undefined images reached the Desktop client as well!
This is now hurting seriously!
Please advice what to do.

I have been having the same issue since we first started using teams in March, everything works in the desktop and mobile apps, but not in the webclient for the same reasons stated here.
If a solution was found, it would be much appreciated.


@Exelscior Not really a solution. But the problem disappeared for me.
What I found out is that it is related to the region. Depending on the serviceURL different image gateways have been used. So sometimes it worked, sometimes it didn't.


I hoped that it was fixed by MS.