Getting "Unable to reach app" in Microsoft Teams conversational bot created using node js.

%3CLINGO-SUB%20id%3D%22lingo-sub-1029886%22%20slang%3D%22en-US%22%3EGetting%20%22Unable%20to%20reach%20app%22%20in%20Microsoft%20Teams%20conversational%20bot%20created%20using%20node%20js.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1029886%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Everyone%2C%3C%2FP%3E%3CP%3EI%20am%20getting%20this%20message%20%22Unable%20to%20reach%20app%22%20while%20adding%20card%20title%20in%20Microsoft%20Teams%20after%20the%20Custom%20Bot%20Application%20is%20deployed%20in%20Teams%20which%20is%20created%20in%20node%20js.%20This%20app%20is%20running%20locally%20in%20my%20machine%20using%20ngrok.%3C%2FP%3E%3CP%3EI%20have%20tried%20different%20solutions%20like%20adjusting%20time%20zone%20and%20also%20have%20correct%20Bot%20Id%20and%20Password%20both%20in%20my%20source%20code%20and%20the%20teams%20app%20details.This%20app%20is%20created%20in%20Visual%20Studio%20Code.%3C%2FP%3E%3CP%3EAnd%20also%20i%20do%20not%20get%20any%20response%20message%20from%20the%20bot%20which%20is%20added%20to%20my%20teams%20channel.%3C%2FP%3E%3CP%3EAny%20solutions%20for%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3EAbhishek%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1029886%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1324744%22%20slang%3D%22en-US%22%3ERe%3A%20Getting%20%22Unable%20to%20reach%20app%22%20in%20Microsoft%20Teams%20conversational%20bot%20created%20using%20node%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1324744%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F468033%22%20target%3D%22_blank%22%3E%40Abhishek%3C%2FA%3E%26nbsp%3BWere%20you%20able%20to%20fix%20this%20in%20the%20end%3F%20I'm%20getting%20the%20same%20issue%20following%20the%20tutorial.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

Hello Everyone,

I am getting this message "Unable to reach app" while adding card title in Microsoft Teams after the Custom Bot Application is deployed in Teams which is created in node js. This app is running locally in my machine using ngrok.

I have tried different solutions like adjusting time zone and also have correct Bot Id and Password both in my source code and the teams app details.This app is created in Visual Studio Code.

And also i do not get any response message from the bot which is added to my teams channel.

Any solutions for this.

 

Thanks

Abhishek

1 Reply
Highlighted

@Abhishek Were you able to fix this in the end? I'm getting the same issue following the tutorial. 

 

Thanks