SOLVED

Error: Operation failed because of a bad request

Occasional Contributor

Our application on Teams apps is: Skill.me 

When some users are trying to access the app - they get this error:
Operation failed because of a bad request

 

This happens even before they sign in to the app from Teams. 

FYI: our application uses AAD-SSO for authentication 

 

This issue was faced by about 3 users in all for the first time and subsequently it worked. There are over 20k users and no one else got this issue. 

 

Can someone help us understand why this error happened and what should we do to make sure users do not see this error again. 

6 Replies

@Billy_Graham - Could you please share the console error which you are getting?

Hi Prasad, our app is a Teams app and we do not have a console error reg the same. We even tried logs - but that too did not capture anything as the error showed up even before the user sign in to the app.
best response confirmed by Billy_Graham (Occasional Contributor)
Solution

@Billy_Graham - The Microsoft Teams bad request error is an error that mostly happens to the web version of the app. If you are trying to access the web client of Microsoft Teams, try changing the web browser to fix the error. At times, the bad cache can create issues with the browser functionality.
If it works without any problem on the desktop app, it is possible that this is a momentary fluke and may resolve itself if left alone.

Hi Prasad, thanks for the clarification. Can this happen within Teams as well? One of our users who faced this issue first saw the error in Teams.
Yes, this can happen in Teams desktop as well.
Thanks for confirming Prasad.