Creating a Team via the Graph giving "The navigation bind for the user was missing in request"

New Contributor

Hi all


We have a solution running for a number of months now using the Graph to create Teams.  It has been working fine up until recently (Monday was when we first noticed), but now when we attempt to create a Team with an owner (using an application permission) we get the response "The navigation bind for the user was missing in request".  Even using the very simple example from the documentation:



{ "template@odata.bind":"'standard')", "displayName":"My Sample Team", "description":"My Sample Team’s Description", "members":[ { "@odata.type":"#microsoft.graph.aadUserConversationMember", "roles":[ "owner" ], "userId":"0040b377-61d8-43db-94f5-81374122dc7e" } ] }



Gives the same response.  As far as I can tell there is no requirement for a navigation bind when specifying the members.  It also happens within the Graph Explorer using delegated permissions and if I remove the members specification the Team is created successfully. 


Any assistance would be greatly appreciated.



5 Replies

@RichardBegg Were you able to resolve this ? I started facing this issue as well.

best response confirmed by RichardBegg (New Contributor)

Hello @RichardBegg,


I had the same error and searching in Microsoft documentation I found this and based on it, I sent the request in the following way:




  "displayName":"My Sample Team",
  "description":"My Sample Team’s Description", 
       "roles":[ "owner" ], 




The request was success.

Hi @LeandroJJ 


Thanks for the pointer, I had thought I'd tried that but on reflection I believe I dropped the user off the beginning!


It had resolved that error, but I'm still unable to create a Team due to the already reported and being investigated issue with the backend template lookup:


Failed to execute Templates backend request CreateTeamFromTemplateRequest
Thanks again.

Can you give us more info about this new issue? 



This is the issue I've found relating to it is:


Happens with education Teams.  As long as I dont specify the visibility I have found it succeeds.