Create schedule for Teams , graph api not working, 204 Response

Occasional Contributor

I am getting 204 response and schedule is not getting created.

 

Here is URL  https://graph.microsoft.com/beta/teams/xxxxxx-ec60-4e63-8d97-a9a127b899c9/schedule

I tried v1.0 and beta both does not work.

 

Here is the input i gave

 

{
'enabled': true,
'timezone': 'America/Chicago'
}

it was PUT request

its giving 204 response and schedule is not getting created.

 

 

 

4 Replies

@Yogi4, Data is getting updated and schedule is getting created but the response is not getting returned. We are checking this internally.

@Abhijit_MSFT  When I fire GetSchedule API it is showing rovision State Failed ...Here is the sample response , And this is not happening for all the calls , some of the calls are success.

 

 

{
  "@odata.context": "https://graph.microsoft.com/v1.0/$metadata#teams('20022699-d70d-4608-ba4d-XXXXXXX')/schedule/$entity",
  "@odata.etag""\"020051ee-0000-0400-0000-XXXXXXX\"",
  "id""20022699-d70d-4608-ba4d-XXXXXXX",
  "enabled": false,
  "timeZone""America/Chicago",
  "provisionStatus": "Failed",
  "provisionStatusCode": "",
  "workforceIntegrationIds": [],
  "timeClockEnabled"false,
  "openShiftsEnabled"false,
  "swapShiftsRequestsEnabled"false,
  "offerShiftRequestsEnabled"false,
  "timeOffRequestsEnabled"false
}

@Yogi4, I missed to respond you here. I have raised a bug to get this resolved.

 

@Abhijit_MSFT  thank you for your response

Can you please help me with ticket number if possible.